No power to fuel pump

Tiny
NJOEHOW
  • MEMBER
  • 2000 MITSUBISHI MONTERO
  • 3.0L
  • V6
  • 2WD
  • AUTOMATIC
  • 102,000 MILES
I have the sport model. I got the car and it had a broken timing belt, when it broke it bent all the valves, so I replaced both heads and cam and crank sensor as the belt ripped the wires when it broke, I got the car to start and run, but it developed a very unusual problem, sometimes when I was driving it would just shut off even a cruising speeds, I would coast to the shoulder and it would start right back up, then one day we went out turned it off and did our errands came out and it would not start, so had it towed home, I checked I was getting spark but no fuel, replaced fuel pump, still no fuel, checked no power to fuel pump, so at this point I've replaced, PCM, immobilizer, key switch and key all programmed together, fuel pump replace, MFI replay, fuel pump control module I have no codes at all. I found corrosion on the wiring just above the relays, as the harness comes out from the firewall, took the harness apart and the wires looked corroded and spliced not factory, order a used harness off of eBay installed it, everything fits. But no plug for the fuel pump control module. So I am not sure what to do at this point.
Do you
have the same problem?
Yes
No
Thursday, December 13th, 2018 AT 6:48 PM

31 Replies

Tiny
DANNY L
  • EXPERT
Hello, I'm Danny.

Okay, so do you need the wiring diagrams for the fuel pump system? Are you sure you got the right year/model harness? Hope this helps and thanks for using 2CarPros.
Danny-
Was this
answer
helpful?
Yes
No
+2
Thursday, December 13th, 2018 AT 7:02 PM
Tiny
NJOEHOW
  • MEMBER
Hi Danny,

This has been a ongoing issue for four years, as I had an injury and couldn't work on this car, trying to get it going now. Yeah that would be great, yes everything plugs in its the right harness, I'm just not sure why there is a different plug there where the fuel pump control module goes. The seller said it fits multiple years, but the harness fits except this plug, are there years that didn't use the fuel pump control module?
Thanks,
Joe
Was this
answer
helpful?
Yes
No
Thursday, December 13th, 2018 AT 7:17 PM
Tiny
DANNY L
  • EXPERT
Hello again,

Here are two pages of the wiring diagram for the fuel pump system.I magnified for you to see better. Hope this helps and feel free to ask any other questions. Thanks for using 2CarPros.
Danny-
Was this
answer
helpful?
Yes
No
+3
Thursday, December 13th, 2018 AT 8:18 PM
Tiny
NJOEHOW
  • MEMBER
Thanks Danny.

Thank you so much. Yeah as I work on this I will need to ask you questions, thanks again. Can I send you a picture of the plug in question to see if you can determine what it might plug into?

Joe
Was this
answer
helpful?
Yes
No
+1
Thursday, December 13th, 2018 AT 8:21 PM
Tiny
DANNY L
  • EXPERT
Hello again,

Yes, feel free to upload pictures here so we can see about things you have questions about. Thanks again for using 2CarPros.
Danny-
Was this
answer
helpful?
Yes
No
+1
Sunday, December 16th, 2018 AT 12:12 PM
Tiny
NJOEHOW
  • MEMBER
Hi Danny,

Okay. So I got under the passenger side of the dash and checked out the wires were the MFI and fuel pump relay are so there is no plug for the fuel pump control module only this plug, I unloaded pics of the plug in question, van you identify this plug? Its right there by where the fuel pump control module plug should be, everything else is there and plugs in and fits. Thanks for your help.
Was this
answer
helpful?
Yes
No
Wednesday, December 19th, 2018 AT 2:47 PM
Tiny
NJOEHOW
  • MEMBER
Hi Danny,

Was wondering if you could tell me where does the white/red wire go from the fuel pump control module? Your schematic shows all the other wires but that one. Thank you

Joe
Was this
answer
helpful?
Yes
No
Wednesday, December 19th, 2018 AT 3:25 PM
Tiny
DANNY L
  • EXPERT
Hi Joe.
That wire plugs into pin #21 at the PCM (Powertrain Control Module)
Hope that helps and keep asking questions if needed. Let's get this figured out! Thanks again for using 2CarPros.
Danny-
Was this
answer
helpful?
Yes
No
+1
Thursday, December 20th, 2018 AT 1:14 AM
Tiny
NJOEHOW
  • MEMBER
Danny,

Okay, great thank you. Any ideas on the electrical connector I sent you pictures of?

Thank you
Was this
answer
helpful?
Yes
No
Thursday, December 20th, 2018 AT 7:38 AM
Tiny
DANNY L
  • EXPERT
Hello again.

Did you check to see if it might be a harness to connect to the HVAC box or blower motor? I've attached a photo with harness/connector information. Hope this helps and thanks again for using 2CarPros.
Danny-
Was this
answer
helpful?
Yes
No
+1
Monday, December 24th, 2018 AT 12:45 AM
Tiny
NJOEHOW
  • MEMBER
Hi Danny,

Okay, so here's what I've done: I checked the harness for a fuel pump control module plug and it is just not there, it is so weird? This harness fits everywhere else, so if there is no FPCM in the harness am I correct in assuming that that circuit is bypassed and goes directly from the fuel pump relay? This thing is throwing me for a loop. Thanks my friend.

Joe.
Was this
answer
helpful?
Yes
No
Thursday, December 27th, 2018 AT 4:54 PM
Tiny
DANNY L
  • EXPERT
Hello again.

The picture is kind of dark. Can you take another picture showing the wire colors on the undetermined plugs? If you upload another picture I'll trace the colors on a wiring diagram. Hope this helps and thanks again for using 2CarPros.
Danny-
Was this
answer
helpful?
Yes
No
+1
Saturday, December 29th, 2018 AT 12:43 AM
Tiny
NJOEHOW
  • MEMBER
Danny,

Here are better pictures:
Was this
answer
helpful?
Yes
No
Saturday, December 29th, 2018 AT 4:48 PM
Tiny
DANNY L
  • EXPERT
Hello again.

Another question. Does this have an aftermarket or stock radio? After looking at the radio wiring diagram it looks like the factory radio amplifier harness. I've attached a picture of the diagram. See if the wire colors match. Otherwise I'll keep looking. Hope this helps and thanks again for using 2CarPros. Happy Holidays!
Danny-
Was this
answer
helpful?
Yes
No
+1
Sunday, December 30th, 2018 AT 10:13 PM
Tiny
NJOEHOW
  • MEMBER
Hi Danny,

Okay yes, it has a factory radio, CD player and an AM/FM radio, I will check.
Was this
answer
helpful?
Yes
No
+1
Monday, December 31st, 2018 AT 3:03 AM
Tiny
DANNY L
  • EXPERT
Hello again.

It sort of looks like the factory amplifier connector. Hope this helps and get back to me. Thanks again for using 2CarPros.
Danny-
Was this
answer
helpful?
Yes
No
+2
Monday, December 31st, 2018 AT 1:12 PM
Tiny
NJOEHOW
  • MEMBER
Danny

Okay, thanks my Monty doesn't have a amplifier I don't think. Okay, so this harness does not have a circuit for the Fuel Pump Control Module then so it should work?

Joe
Was this
answer
helpful?
Yes
No
Monday, December 31st, 2018 AT 2:02 PM
Tiny
DANNY L
  • EXPERT
Hello,

It only shows having both fuel pump relay and fuel pump module. Both behind right kick panel. Pictures with wire colors below.
Danny-
Was this
answer
helpful?
Yes
No
Monday, December 31st, 2018 AT 4:11 PM
Tiny
NJOEHOW
  • MEMBER
Danny,

Okay thanks so much. So I'm a bit confused why this harness has no plug for the fuel pump control module? So in your professional option if I get no power to the fuel pump again once I try to start, could I go from the fuel pump relay directly to the fuel pump? This is so weird everything else plugs in, but there is no FPCM plug in the harness I'm stumped. Thanks again for your help.

Joe
Was this
answer
helpful?
Yes
No
Monday, December 31st, 2018 AT 4:22 PM
Tiny
DANNY L
  • EXPERT
Hello again.

Just curious. Have you physically located both the module and the relay behind the kick panel? Are you saying you located them both but you only have a connector that fits the relay and not the module?

Danny-
Was this
answer
helpful?
Yes
No
Monday, December 31st, 2018 AT 4:31 PM

Please login or register to post a reply.

Sponsored links