Change fuel pump, relays and power transistor and it wont start

Tiny
FRANCISCOBERMUDEZ
  • 1997 MITSUBISHI MONTERO
  • 316,000 MILES

I have 1997 mitsubishi montero 3.5L V6 and a I have change the fuel pump, cam and crank sensor, fuel pump relays and the power transistor, still it wont start, what could it be?

Do you
have the same problem?
Yes
No
Sunday, August 19th, 2012 AT 6:42 PM

14 Replies

Tiny
ASEMASTER6371
  • EXPERT
  • 25,517 POSTS

Start with basics. Check compression, fuel pressure and spark.

Find what is missing and we go from there.

Roy

Was this
answer
helpful?
Yes
No
Sunday, August 19th, 2012 AT 6:46 PM
Tiny
FRANCISCOBERMUDEZ
  • MEMBER

Already did that and nothing, the fuel pressure comes ok

Was this
answer
helpful?
Yes
No
Sunday, August 19th, 2012 AT 6:48 PM
Tiny
FRANCISCOBERMUDEZ
  • MEMBER

The thing is my fuel does not receives electricity

Was this
answer
helpful?
Yes
No
+1
Sunday, August 19th, 2012 AT 7:01 PM
Tiny
ASEMASTER6371
  • EXPERT
  • 25,517 POSTS

Ok, what is the compression?

Where did you test for power for fuel pump?

Roy

Was this
answer
helpful?
Yes
No
Sunday, August 19th, 2012 AT 7:08 PM
Tiny
FRANCISCOBERMUDEZ
  • MEMBER

The fuel pump is not receiving electricity, I check the relays they are new

Was this
answer
helpful?
Yes
No
-1
Sunday, August 19th, 2012 AT 7:46 PM
Tiny
ASEMASTER6371
  • EXPERT
  • 25,517 POSTS

Where did you check for voltage? At the pump or relay?

Roy

Was this
answer
helpful?
Yes
No
Sunday, August 19th, 2012 AT 7:47 PM
Tiny
FRANCISCOBERMUDEZ
  • MEMBER

In both, in the relay says 12v in the pumo says 0.22v

Was this
answer
helpful?
Yes
No
Sunday, August 19th, 2012 AT 7:49 PM
Tiny
ASEMASTER6371
  • EXPERT
  • 25,517 POSTS

Ok, the relay needs 2 12 volt feeds. One for the control and one for load. Do you have 2 hot terminals?

Roy

Was this
answer
helpful?
Yes
No
Sunday, August 19th, 2012 AT 7:53 PM
Tiny
FRANCISCOBERMUDEZ
  • MEMBER

Yes, there are two relays, ehat do you mean wuth hot terminala?

Was this
answer
helpful?
Yes
No
Sunday, August 19th, 2012 AT 7:55 PM
Tiny
ASEMASTER6371
  • EXPERT
  • 25,517 POSTS

No, 1 relay. There are to be 2 terminals that have 12 volts on the connector.

Roy

Was this
answer
helpful?
Yes
No
Sunday, August 19th, 2012 AT 8:00 PM
Tiny
FRANCISCOBERMUDEZ
  • MEMBER

In 1 relay there is only one terminal with 12v

Was this
answer
helpful?
Yes
No
Sunday, August 19th, 2012 AT 8:15 PM
Tiny
ASEMASTER6371
  • EXPERT
  • 25,517 POSTS

Ok, thats most likely your issue. You need 2 feeds. Check the diagram I sent you

Roy

Was this
answer
helpful?
Yes
No
Sunday, August 19th, 2012 AT 9:05 PM
Tiny
FRANCISCOBERMUDEZ
  • MEMBER

Where is the terminal harness side conector

Was this
answer
helpful?
Yes
No
Sunday, August 19th, 2012 AT 9:31 PM
Tiny
ASEMASTER6371
  • EXPERT
  • 25,517 POSTS

It sounds like you need help. Maybe you should get a shop to help you with this as you need experience to attempt this diag.

Roy

Was this
answer
helpful?
Yes
No
Please consider a donation if we helped you
Sunday, August 19th, 2012 AT 10:09 PM

Please login or register to post a reply.

Related Fuel System Fuel Pump Relay Replace/Remove Questions

Recommended articles