No fuel pressure at the rail

Tiny
JOEEGER52
  • MEMBER
  • 2010 CHEVROLET COBALT
  • 2.2L
  • 4 CYL
  • 2WD
  • MANUAL
  • 97,000 MILES
I'm only getting 2.4V at the fuel pump relay, coming from the ECM. Would this indicate that the ECM needs replaced? Also, where is the ground G402 located? Everything I found, says it's located near LR speaker. I can't find it anywhere. Thanks in advance!
Do you
have the same problem?
Yes
No
Sunday, December 8th, 2019 AT 7:45 PM

3 Replies

Tiny
KASEKENNY1
  • EXPERT
This could be the ECM however, you are on the right path with checking the ground.

Here is a test that you can run through with this but if you have a loose ground then it can cause low voltage. However, 2.4V is very low and most likely not a ground issue.

Let's start with checking for codes and then run through this test and I am sure we will find the issue. Let me now what you find for codes and we can go from there. Thanks
Was this
answer
helpful?
Yes
No
Monday, December 9th, 2019 AT 5:42 PM
Tiny
JOEEGER52
  • MEMBER
I do not have access to a scanner to get the codes. I'm going to look for that ground. If that's not it, I guess it'll get towed to a garage. I appreciate your time and help. Thank you
Was this
answer
helpful?
Yes
No
Monday, December 9th, 2019 AT 6:21 PM
Tiny
KASEKENNY1
  • EXPERT
Okay. Please keep us updated on what you find or if you want to use us as a second opinion of what a shop finds. Thanks
Was this
answer
helpful?
Yes
No
Monday, December 9th, 2019 AT 6:41 PM

Please login or register to post a reply.

Sponsored links