A/C

Tiny
MCMYANKS
  • MEMBER
  • LINCOLN TOWN CAR
I have a 2000 Licoln Towncar 4.6l V8. 253,000. When I turn on my AC I can hear it come on, but no air comes out not even when I turn on the heater. What could it be. I was told maybe some kind of modulator?
Do you
have the same problem?
Yes
No
Thursday, October 4th, 2007 AT 8:06 PM

1 Reply

Tiny
TOBYU
  • MEMBER
Sounds like your blower motor is bad. It could be stuck also.
It is under the hood ,on the passenger side, up by the firewall (back of dash)
You can see the round black part that mounts to the firewall duct system and the motor is about 3.5 inch diameter by 3-4 inches long....a cylinder looking motor.


http://www.2carpros.com/forum/automotive_pictures/118244_blower_1.jpg


This is a profile pic the left front of this pic would be inside the firewall duct system with a squirrel cage fan on it.
There is a small black vent tube on the bottom of the motor. It pops i like a rubber grommet. You can pop it out and stick your finger in the hole and turn the motor a little bit....or hit the end or motor with a metal rod or bar....this will sometimes jar it into working.....
If no spinning...you can unhook the wire connector on it and use a volt meter or test light to see if you are getting power when the key is on and the fan is turned on....
If you are getting voltage and it is not spinning then you have a bad motor. New ones are about 45.00 from parts stores and more form dealer.
On this particular item...the aftermarket ones seem to last just as long as the OEM ones.
There are certain parts I WILL NOT use aftermarket on....In this case it would be your decision.
Was this
answer
helpful?
Yes
No
Friday, November 16th, 2007 AT 1:15 AM

Please login or register to post a reply.

Recommended Guides