Jeep engine races when in park

Tiny
TAMALIE
  • MEMBER
  • JEEP CHEROKEE
I have inherited my late brothers 97 jeep grand cherokee. It has about 63000 miles on it. It had been sitting for about a year. I had it worked on last week and it was running fine. There was a small problem with the transmission shifting properly and it needed t be cleaned out from sitting so long. This morning when we started it, the engine started racing when it was in park. When we shift into another gear, it's fine, but put it back in park and it's racing at about 2500 rpm's. If anyone can tell me what I need to have checked I would really appreciate it.
Do you
have the same problem?
Yes
No
Saturday, December 30th, 2006 AT 12:25 AM

3 Replies

Tiny
SERVICE WRITER
  • EXPERT
Is it the same when warm?

I would first check for a vacuum leak.
Was this
answer
helpful?
Yes
No
Saturday, December 30th, 2006 AT 8:42 AM
Tiny
TAMALIE
  • MEMBER
Thanks for your response! Yes, it does the same thing whether it's cold or has been driven for 20 minutes or so. My daughter was driving it home and had a flat, locked the keys in the car and the battery went dead (flashers and radio on) waiting for the courtesy patrol and a locksmith. They got it all fixed and jumped the jeep off and it was fine at that point. After driving for about 20 minutes to a service station is when it first happened. Now it does it every time we put it in park. Your question made me wonder if it was just happening in park and it appears that it's happening in every gear except drive. When we start it, the engine is revved up through every gear until we hit drive and then it jerks and slows down. My daughter also stated that it felt "jerky" while she was driving it If you have any thoughts, I would really appreciate it. Finding an honest mechanic around here is a bit difficult and it would help to know what I needed to have repaired.

Thanks!
Was this
answer
helpful?
Yes
No
Saturday, December 30th, 2006 AT 11:48 AM
Tiny
SERVICE WRITER
  • EXPERT
If I understand you, the high idle was there. The truck battery went dead, it was jumped. It ran fine for 20 mins and then started back to a high idle again.
Was this
answer
helpful?
Yes
No
Saturday, December 30th, 2006 AT 9:56 PM

Please login or register to post a reply.

Recommended Guides