89 Cherokee hard to start, idles fine, loses power on acelera

Tiny
SAMUELJE93
  • MEMBER
  • 1989 JEEP CHEROKEE
I have a 1989 Cherokee, 4.0, automatic, 4WD, with Fuel injection. The Jeep has 142,000 miles but the engine only has 23,000 miles. It is a Jasper engine.
I've owned it for several months. It has always been hard to start but other than a little hesitation on take off, ran great. It recently started losing power on acceleration. It runs good when in low gear but when
it changes gears, it loses power and has a slight miss and backfire. It has good fuel pressure and compression. Parts I have replaced are: fuel filter, map sensor, temperature sensor, air control sensor, crank position sensor, and pick up coil. Nothing has helped. I'm at my wits end and I appreciate any help you can give me. Thanks, Roger
PS: I definitly will make a donation on payday
because I probaly will be visiting this site often.

Could this possibly be a stopped up catalytic converter?
Do you
have the same problem?
Yes
No
Saturday, May 19th, 2007 AT 9:06 AM

1 Reply

Tiny
SAMUELJE93
  • MEMBER
I'm a little curious, it seems to me, I see all these visits to these questions but all I ever see on replies is mostly 0. Is this just an open forum for people to respond or are there actually "professionals" that answer questions? Are questions only answered by
the experts if ya Actually "donate" upfront?
I am new to this and am really a little confused and
a lot disappointed. Thanks, roger
Was this
answer
helpful?
Yes
No
Thursday, May 24th, 2007 AT 9:23 PM

Please login or register to post a reply.

Recommended Guides