Instrument cluster (possible short)

Tiny
BOB FINGERHUT
  • MEMBER
  • 1997 BUICK REGAL
  • 3.8L
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 177,000 MILES
The car would not start after it sat for four weeks. I jump started it. I noticed that the transmission gear did not display on the instrument cluster. The odometer reading also does not display but the trip distance does. It will not switch between trip distance and odometer. Two orange boxes show above where the transmission gear should display. They contain the numbers 1 and 2. The coolant temperature is reading 3/4 the way to hot now instead of 1/2. For a couple of days it was pegged at hot (even when the engine was off and cold). It has now returned to 3/4 the way to hot. The coolant level is full. The car starts and runs good for a day after I jump start it. After that, I have to jump it to get it to start. The alternator is supplying 14.5 volts.
Do you
have the same problem?
Yes
No
Wednesday, September 12th, 2018 AT 1:03 PM

1 Reply

Tiny
JACOBANDNICKOLAS
  • MECHANIC
  • 107,696 POSTS
Hi and thanks for using 2CarPros.com.

If the battery is good and still goes dead overnight, then there is a parasitic draw on the system. Take a look through this link and let me know if it helps. I noticed that you indicated "little knowledge," so I also attached links to help you use the necessary basic test equipment you will need. The last link discusses how to check wiring.

https://www.2carpros.com/articles/car-battery-dead-overnight

https://www.2carpros.com/articles/how-to-use-a-test-light-circuit-tester

https://www.2carpros.com/articles/how-to-use-a-voltmeter

https://www.2carpros.com/articles/how-to-check-wiring

Let me know if this helps or if you have other questions. '

Take care,
Joe
Was this
answer
helpful?
Yes
No
Wednesday, September 12th, 2018 AT 7:22 PM

Please login or register to post a reply.

Sponsored links