HVAC Fan Not Working Properly

Tiny
EWOOD429
  • MEMBER
  • 1991 CHEVROLET 1500
  • 5.0L
  • V8
  • 4WD
  • AUTOMATIC
  • 87,000 MILES
I have a 1991 C1500. Recently replace the blower motor. Last week the blower motor started only operating on one speed. Runs on low and medium but not on high. When I say runs only runs on the same speed. Took it back to the shop that put the blower motor in and they say the HVAC switch is bad. In looking at the switch it appears fully functioning. I had a friend who is into electronics. He fixed my original Delco radio so he knows his stuff. Retired military. He couldn’t find a diagram for the box so it was hit or miss. Replaced some bad diodes but it didn’t fix the issue. Any suggestions? The repair shop said the resister was ok.
Do you
have the same problem?
Yes
No
Monday, October 21st, 2019 AT 5:30 PM

1 Reply

Tiny
JACOBANDNICKOLAS
  • EXPERT
Welcome to 2CarPros.

Has the relay been checked? Also, I feel like I answered this question. I may be going nuts. LOL

There are two relays related to the blower motor. I attached a pic of them and their locations. Here is a link that shows how a relay is tested:

https://www.2carpros.com/articles/how-to-check-an-electrical-relay-and-wiring-control-circuit

Let me know. Also, disconnect the connector at the blower motor and check for power in all speeds.

Here are a few links you may find helpful:

https://www.2carpros.com/articles/how-to-use-a-test-light-circuit-tester

https://www.2carpros.com/articles/how-to-use-a-voltmeter

https://www.2carpros.com/articles/how-to-check-wiring

______________________

Interestingly, you mentioned the resister is good. And based on symptoms, it does sound good. Most times when one fails, only the high speed will work and nothing else. However, I would still remove and inspect it for damage.

Let me know what you find or if you have other questions.

Take care,
Joe
Was this
answer
helpful?
Yes
No
Thursday, October 24th, 2019 AT 7:34 PM

Please login or register to post a reply.

Sponsored links