While driving the engine is shutting off and running rough?

Tiny
RED101902
  • MEMBER
  • 2007 CHEVROLET IMPALA
  • 3.5L
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 170,000 MILES
My fiancé said there was a slight misfire. Which I agreed, so we got spark plugs and wires. (Yes, we didn’t get the expensive ones we got the cheap ones because we don’t have much money) after doing so, the car was running rough and had multiple new things pop up on the computer. So, we changed what it said to change. The coil pack, (it ran somewhat decent afterwards but wanted. To go ahead and fix the other code) and the camshaft position sensor. (It ran like horribly afterwards and said engine power reduced) Then we were driving it going up a bridge and the car shut off and said starting disabled, service throttle. Had to coast down the bridge. So, it did it once in 3-4 days. Then it started shutting off on us trying to back up and idling rough. So, we looked it up and said the TPS. So, we changed it. Still running rough and idling rough. So, we changed the map sensor (because there were similar symptoms to what we were having). We are at a loss for words. We have no clue what to change or do at this point and only need advice.
Do you
have the same problem?
Yes
No
Saturday, October 1st, 2022 AT 9:47 PM

1 Reply

Tiny
KEN L
  • ADMIN
Can you please let us know what codes are coming up? Also, you said you changed the TPS? On this car the TPS is internal with the throttle body. This guide can help you get the codes so you can let me know what it comes up with. Also, I would change out the ignition parts with AC Delco parts. Try Rockauto.com

https://www.2carpros.com/articles/checking-a-service-engine-soon-or-check-engine-light-on-or-flashing

Please go over this guide and report back.
Was this
answer
helpful?
Yes
No
Monday, October 3rd, 2022 AT 10:16 AM

Please login or register to post a reply.

Sponsored links