Fuel flow problem car feels heavy when trying to accelerate

Tiny
ACQUAHFELIX
  • MEMBER
  • 2000 FORD FOCUS
  • 1.6L
  • 2WD
  • MANUAL
  • 253,255 MILES
My vehicle occasionally stalls as if I have run out of fuel but not. My mechanic has changed the fuel pump twice as well as the fuel filter. Again as soon as the air condition is put on, the car becomes so heavy for want of better word that when you accelerate. It does not seem to pull as it should unless you again switch off the air-condition. My car has a manual transmission.
Do you
have the same problem?
Yes
No
Sunday, December 25th, 2016 AT 9:17 PM

6 Replies

Tiny
HMAC300
  • EXPERT
Try cleaning throttle plate on both sides and IAC hole with choke cleaner first. Check for a vacuum leak like a hose off broken etc.
Was this
answer
helpful?
Yes
No
Monday, December 26th, 2016 AT 7:09 AM
Tiny
ACQUAHFELIX
  • MEMBER
My Mechanic has already cleaned both throttle plate, but he has not cleaned the Idle air control valve. Will ask him to clean it and will revert. Thanks so much.
Was this
answer
helpful?
Yes
No
Monday, December 26th, 2016 AT 8:01 AM
Tiny
HMAC300
  • EXPERT
If this is a diesel we have not information on it as most here in USA have a 2.0l, but ours has a fuel pump module driver which the mechanic may have to scan for codes as that controls the fuel pump so that may be your cause other than that. We do not have any information for this. See picture.
Was this
answer
helpful?
Yes
No
Monday, December 26th, 2016 AT 9:40 AM
Tiny
ACQUAHFELIX
  • MEMBER
My vehicle is petrol engine Ford focus. My Mechanic has remove and cleaned IAC valve with choke carburetor cleaner as directed. I tried the vehicle thereafter on a shorter distance and it was cool. I'm yet to travel with it to finally confirm its success. Once again many thanks for your information.
Was this
answer
helpful?
Yes
No
Monday, December 26th, 2016 AT 8:25 PM
Tiny
ACQUAHFELIX
  • MEMBER
Again kindly help me my AC switch #1&2 does not work. Only 3&4 works. How do I resolve this issue too?
Was this
answer
helpful?
Yes
No
Monday, December 26th, 2016 AT 8:30 PM
Tiny
HMAC300
  • EXPERT
Check the resistor normally by the blower motor see if power comes to it then goes out a lot of times the resistor burns out and doesnt' send power so no blower on that speed. If 4 is high check blower relay underhood.
Was this
answer
helpful?
Yes
No
Tuesday, December 27th, 2016 AT 5:41 AM

Please login or register to post a reply.

Recommended Guides