Passenger side window switch

Tiny
SMASSIE
  • MEMBER
  • FORD WINDSTAR
Greetings,

I have a 1999 Ford Windstar, 184,000 mi, 3.8L v6.
I pulled the switch for the front passenger window today since it hasnt worked in three months.

After putting the door back together the engine would not start. I tried to put the switch back in but when it was plugged back in, the seemed to short out the radio. (Pushing the switch would cause the radio to cut out for about 5 seconds)

Now I have the switch pulled, but the engine will not turn over at all. It sounds like the clicking when the battery is low, or the alternator is going bad.
On top of that, I have no radio, no headlights and neither of the front door controls will work. (Windows or door locks).

I checked all of the fuses under the dash, but none of the relays. (I'm not sure how to check those). I also checked most of the fuses under the hood as well, but none of the relays.

Any ideas what I could have fried to kill the entire van?

Thank you for any and all help or suggestions.

Smassie
Do you
have the same problem?
Yes
No
Saturday, November 17th, 2007 AT 6:48 PM

1 Reply

Tiny
SMASSIE
  • MEMBER
Charged the battery and it started up fine.

Is it possible then that a short can drain the battery in a matter of a half hour? Thats about how long it took me to pull the switch and find out that it wouldn't start.

Strange but crisis averted.

Thank you very much for the prompt response and the fix to my problem.
Was this
answer
helpful?
Yes
No
Sunday, November 18th, 2007 AT 1:02 PM

Please login or register to post a reply.

Sponsored links