Low Coolant Light On

Tiny
DEEBEE
  • FORD TAURUS

2000 Ford Taurus 70K Miles. My low coolant light had been coming on occasionally over the past six weeks or so. Happening more frequently now. Coolant reservoir is full, with no apparent leaks. Any ideas what the problem could be? Thanks in advance.

Do you
have the same problem?
Yes
No
Tuesday, January 2nd, 2007 AT 7:07 AM

3 Replies

Tiny
SERVICE WRITER
  • EXPERT
  • 9,242 POSTS

Somtimes the sensor will go bad in the reservior. Rap on the sensor lightly and see if anything changes. You have flushed the coolant by now right?

Was this
answer
helpful?
Yes
No
Tuesday, January 2nd, 2007 AT 7:08 AM
Tiny
DEEBEE
  • MEMBER

No, coolant is still original as far as I know. Where is the sensor located? Thanks again!

Was this
answer
helpful?
Yes
No
Tuesday, January 2nd, 2007 AT 7:16 AM
Tiny
SERVICE WRITER
  • EXPERT
  • 9,242 POSTS

Get the coolant flushed. The properties of the coolant get diminished and create a situation where you'll have to spend more time here. :)

The coolant level sensor may be part of the cap on the reservior or at the bootmo of the reservior. You see and electrical harness going to it either way. It may not change when you tap on it or it may. I don't recall any other problems that I encountered for triggering that light, unless the reservior was really low.

Was this
answer
helpful?
Yes
No
+1
Please consider a donation if we helped you
Tuesday, January 2nd, 2007 AT 7:37 AM

Please login or register to post a reply.

Related Low Coolant Light Questions

Recommended articles