2003 TAURUS ELECTRICAL PROBLEMS

  • Tiny
  • Jason Golembiewski
  • 2003 FORD TAURUS

I have a 2003 Taurus SE 3.0l OHC 6 cylinder Flex fuel vehicle. I recently drove off a curb (accidentally) and the tremendous shake caused some huge electrical problems. The windshield wipers will no longer work and neither will the radio. The power windows will only work after the car has been on for about 45 seconds. I checked all the fuses and none seem to be bad. I replaced the GEM module and still nothing has changed. I'm not sure where to go from here, any ideas or suggestions would be great. There is a wiring harness still connected to the radio from the previous owners, but it is not connected to anything else. The radio is the stock radio. Please help me!

Do you
have the same problem?
Yes
No
Friday, October 12th, 2007 AT 6:40 PM

2 Replies

  • Tiny
  • Merlin2021
  • EXPERT
  • 17,582 POSTS

Only things I can think of is did the battery shift? Positve terminal may have grounded. Or check to see if you damaged any wires that run up thru the fender wells, behind the inner fenders!

Was this
answer
helpful?
Yes
No
Saturday, October 13th, 2007 AT 8:08 AM
  • Tiny
  • Jason Golembiewski
  • MEMBER

I had an untrustworthy mechanic work on it and this is what he told me "there was a wire with a short in it, black with green chaser. It seems to of been a surge protector, I couldn't figure out exactly what it was for, but when I removed it everything worked, so I took it out and now everything works fine.&Quot;

i have no idea what happened, but it works now, thanks merlin!

Was this
answer
helpful?
Yes
No
Tuesday, October 16th, 2007 AT 7:20 PM

Please login or register to post a reply.

Other GEM Replace/Remove Questions