1992 Ford Taurus Problem with Turn Signals

Tiny
DRAGONFLY1
  • MEMBER
  • 1992 FORD TAURUS
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 100,000 MILES
While trying to install radio in my Taurus, 3 fuses where blown - after replacing the blown fuses & checking the rest I started the car & the left turn signal is flashing (fast like it does when the bulb goes out), the left signal wont work at all, AND it wont stop either! I actually had to remove the bulb from the housing because it has almost caused accidents obviously because people think Im turning left when Im not. The bulbs are ok, no fuses are blown.I am not understanding why the indicator continues to flash as though its stuck almost.I am completely frustrated so any help would be appreciated!
Do you
have the same problem?
Yes
No
Saturday, March 1st, 2008 AT 1:29 AM

3 Replies

Tiny
JACK42
  • MEMBER
Sounds like a broken turn signal switch. Does the right signal work ok? Bulbs flash front and rear on the left side?
Was this
answer
helpful?
Yes
No
Saturday, March 1st, 2008 AT 7:13 AM
Tiny
DRAGONFLY1
  • MEMBER
No, the right turn signal does not work at all - its completely dead compared to the left one that wont STOP flashing (I had to remove the left bulb in front & back - I should also mention that the left indicator on the inside of the car continues to flash!).
And the answer to your next question is yes, the bulbs flash front & rear on the left side (obviously not now since I have removed both front & rear bulbs on the left side).
You mentioned a broken turn signal switch - I should also let you know that we just replaced that not even 3 weeks prior to this incident w/ the signals. It was the "Combination Switch" to be exact, & it wasnt because the turn signals werent working, it was because the windshield wipers had stopped working.
I was wondering if its possible that we could have damaged that new switch somehow when we were trying to install the radio & ended up blowing those 3 fuses because the turn signals worked just fine right before we blew those fuses. Do you think we could've damaged the entire switch.
Someone also said something to me about the "flasher" or the "turn signal relay". But I have no idea where those things are even located in the car much less what they are.
Was this
answer
helpful?
Yes
No
Saturday, March 8th, 2008 AT 3:31 AM
Tiny
JACK42
  • MEMBER
Sounds like you may be onto something. If all worked prior to installing the combo switch, I think you may have a pinched wire or the such. Take the plastic covers back off and inspect all the wiring.
Was this
answer
helpful?
Yes
No
Saturday, March 8th, 2008 AT 8:10 AM

Please login or register to post a reply.

Recommended Guides