2001 Ford Taurus Directionals and/or Flasher

Tiny
TAURUSFAN01
  • MEMBER
  • 2001 FORD TAURUS
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 121,000 MILES
My left front directional is stuck on and the left directional on the dash stays lit. I thought it might be a bad bulb so I replaced it, that wasn't it. I bought a new flasher relay and replaced that. That wasn't it either. The right side is working fine on the dashboard and the front and rear lights. I'm perplexed. Any help?
Do you
have the same problem?
Yes
No
Thursday, May 6th, 2010 AT 9:01 PM

4 Replies

Tiny
BMRFIXIT
  • EXPERT
Left front on, what about the rear?
You have a bulb out
put 4way flasher on and compare the left with the right, looking for a missing bulb
Was this
answer
helpful?
Yes
No
Friday, May 7th, 2010 AT 5:19 AM
Tiny
TAURUSFAN01
  • MEMBER
The left rear was also on, not blinking, when the car was running or ignition on. When the car was turned off, it was off but the left front stayed on. I had to take the bulb out of the socket so that it wouldnt' kill my battery overnight.
Today, I checked the rear bulb and found it to be the incorrect bulb for the car. (I bought this car a couple months ago). I put the correct bulb in and it started blinking properly and the dash light started flashing properly also so I then put the front bulb back in and it also flashed properly, for about 10 seconds. Then, they all stopped flashing and it was back to the same old thing. Front stays on, won't shut off. Rear will shut off when ignition off. Left directional light stays on all the time.
Strange.
Was this
answer
helpful?
Yes
No
Friday, May 7th, 2010 AT 6:56 PM
Tiny
BMRFIXIT
  • EXPERT
PROBLEM IS IN THE REAR CHECK WIRING, SOCKET AND BULB
CHECK FOR GROUND
Was this
answer
helpful?
Yes
No
Friday, May 7th, 2010 AT 7:02 PM
Tiny
TAURUSFAN01
  • MEMBER
I don't know what happened but I had been driving for a little while without the left front directional bulb in the socket. The left rear wasn't working either. For whatever reason, I was taking a left turn one day and the turn signal arm, by accident, I pushed forward, as if I were flashing the high beams. Well, the instrument panel directional starting flashing quickly so I stopped the car to see if my left rear directional began working. I don't know why. I drove like this for a few days then put the bulb back in the left front and all are working fine again, like nothing happened. Very strange.
Was this
answer
helpful?
Yes
No
Friday, June 4th, 2010 AT 7:10 AM

Please login or register to post a reply.

Recommended Guides