1993 Ford Probe No Power

Tiny
HAWKERTROY
  • MEMBER
  • 1993 FORD PROBE
  • 6 CYL
  • FWD
  • MANUAL
  • 121,000 MILES
My sons Probe GT(used to be mine) sat for four months with a dead battery, outside in the weather. I replaced the battery and there isn't any power past the fuse box under the hood. I did a logic test and there seems to be power there, but nothing inside the cockpit. I thought it might be the ignition relay, but don't want to shell out 135 skins to find out for sure.
Thanks
T.
Do you
have the same problem?
Yes
No
Thursday, January 8th, 2009 AT 12:15 AM

3 Replies

Tiny
DAVE H
  • EXPERT
Is there power going to the dashboard. Lights come on etc.. If so have you disabled the alarm immobolizer by locking and unlocking the drivers door lock?. The immobolizer cuts power to the starter relay. Let me know
Was this
answer
helpful?
Yes
No
Tuesday, January 20th, 2009 AT 7:02 PM
Tiny
HAWKERTROY
  • MEMBER
Thats the problem, no juice past the primary fuse box. The cockpit is dead. No alarm or keyless entry installed. Dome light or courtesy lights don't even come on. Thanks for the reply.T
Was this
answer
helpful?
Yes
No
Friday, January 23rd, 2009 AT 7:14 PM
Tiny
DAVE H
  • EXPERT
Sorry didn't get back to you sooner .. had problems with my computer !! have you checked with voltmeter for power (black/blue wire) @ ignition switch ? I'm thinkin is the switch faulty ? if no pwer going to the switch .. first place to check is fuses .. which obviously you have already checked .. then the wiring underneath the fuse box ? let me know


http://www.2carpros.com/forum/automotive_pictures/266999_probe_3.jpg



http://www.2carpros.com/forum/automotive_pictures/266999_probe1_1.jpg

Was this
answer
helpful?
Yes
No
Saturday, January 24th, 2009 AT 7:27 PM

Please login or register to post a reply.

Recommended Guides