Ford Probe

Tiny
COOPER55
  • 1993 FORD PROBE
  • 4 CYL
  • FWD
  • MANUAL
  • 180,000 MILES

I have a 1993 ford probe it starts up and runs ok when cold but once it gets warm it starts to bog down have no power and stalls on me and jumps around alot

Do you
have the same problem?
Yes
No
Wednesday, July 6th, 2011 AT 7:01 PM

3 Replies

Tiny
RASMATAZ
  • MEMBER

Check engine light On and when was last tune-up?

Could be caused by one of the following below

Oxygen sensor.
Catalytic converter.
Fuel injectors dirty/sticking.
Mass airflow sensor/Airflow meter.
Throttle position sensor.
Crankshaft position sensor
Knock sensor
Manifold absolute pressure sensor.
EGR Valve
Fuel pressure regulator leaking or defective fuel pump.
Fuel contamination.
Foul/defective spark plugs.
Open spark plug wires.
Ignition coil/Coil packs defective.
Incorrect ignition timing.
Cap and rotor.

Note:If it doesn't apply disregard it and keep testing.

Was this
answer
helpful?
Yes
No
Wednesday, July 6th, 2011 AT 8:34 PM
Tiny
CARADIODOC
  • EXPERT
  • 26,053 POSTS

Add to the list:

Check the fresh air tube between the mass air flow sensor and throttle body for cracks or other air leaks.

Was this
answer
helpful?
Yes
No
Wednesday, July 6th, 2011 AT 8:47 PM
Tiny
RASMATAZ
  • MEMBER

I should add that on my grocery list instead of just the sensor-Thanks for the heads-up Have a nice one

Was this
answer
helpful?
Yes
No
Wednesday, July 6th, 2011 AT 9:00 PM

Please login or register to post a reply.

Other Engine Low Power Questions