Fog lights

Tiny
LYNNPRINCE01
  • MEMBER
  • 2004 FORD F-150
  • 5.4L
  • V8
  • 4WD
  • AUTOMATIC
  • 20 MILES
Fog lights stop working, I replaced bad one. Still not work I replaced relay an fuse. Still not working. What am I missing
Do you
have the same problem?
Yes
No
Saturday, March 26th, 2016 AT 2:36 PM

7 Replies

Tiny
HMAC300
  • EXPERT
Check items in pic like grounds etc. It may be a broken or shorted wire or bad connection at relay, try some dielectric grease on prongs of relay about $2 on counter at auto parts.
Was this
answer
helpful?
Yes
No
Saturday, March 26th, 2016 AT 3:51 PM
Tiny
LYNNPRINCE01
  • MEMBER
Ok, funny they was just working fine
Was this
answer
helpful?
Yes
No
Saturday, March 26th, 2016 AT 4:12 PM
Tiny
KEN
  • ADMIN
This problem could be the switch, can you please re-upload the pic harry? It didn't show up
Was this
answer
helpful?
Yes
No
Monday, March 28th, 2016 AT 9:43 AM
Tiny
HMAC300
  • EXPERT
I either forgot or another problem
Was this
answer
helpful?
Yes
No
Monday, March 28th, 2016 AT 12:03 PM
Tiny
LYNNPRINCE01
  • MEMBER
I was told check back of fuse box an connection
Was this
answer
helpful?
Yes
No
Monday, March 28th, 2016 AT 5:15 PM
Tiny
KEN
  • ADMIN
Have you checked for power and ground at the bulb, here is a guide it is for the rear lights but your problem follows the same method.

http://www.2carpros.com/articles/no-tail-lights-exterior-running-lights-tail-lights-out

Let me know what you find
Was this
answer
helpful?
Yes
No
Monday, March 28th, 2016 AT 5:21 PM
Tiny
HMAC300
  • EXPERT
Originally I sent a pic that didn't show up the fog lights operate off the same relay etc. You had stated that the one side worked which in the pic both operate off the same relay so it could be a wiring issue like shorting out or partially broken between LH and RH sides. So make sure to check that. The smart box problem I thought was limited to expeditions but not really sure. It is 2003-06 that have that problem and it's normally the fuel pump circuit that screws up, not the lights. So check the wiring in the pic as it may have a problem there it is the same color on both sides. Also check the grounds as they are separate and could be the problem for one light.
Was this
answer
helpful?
Yes
No
Monday, March 28th, 2016 AT 5:38 PM

Please login or register to post a reply.

Recommended Guides