Engine misfiring

Tiny
SARGEANDY
  • MEMBER
  • 2015 VAUXHALL ASTRA
  • 1.6L
  • 4 CYL
  • 2WD
  • MANUAL
  • 30,000 MILES
My car's engine is misfiring. It started a few weeks ago where it would stutter a little bit, more noticeable in low revs. I've had the ESP light come on a couple of times, but go off again. Now it's come on and I've cleared it but it comes back very quickly and it feels like it's misfiring constantly now.
I plugged the car in using opcom and got Engine misfire detected P300-00 and in the Brake module I got "U0100 lost communication with Engine control module - invalid data".
My first guess would be the coil pack, though it seems strange for that to affect the ESP, though perhaps that's just because it's invalid data?
Do you
have the same problem?
Yes
No
Wednesday, June 12th, 2019 AT 12:41 AM

1 Reply

Tiny
KASEKENNY1
  • EXPERT
Hi Sargeandy,

This sounds more like a fuel issue. the P0300 code is a multiple cylinder misfire. This means that the one cylinder can misfire and then the next time it does not but a different cylinder misfires. Basically, this is a misfire that does not have any consistency to it.

There are a number of things that can cause this but the most common cause is the fuel system because we are looking for something that effects all cylinders not just one.

This could also be a coil but again, this is less likely than fuel.

https://www.2carpros.com/articles/engine-misfires-or-runs-rough

I would suggest starting with getting the fuel pressure while this is misfiring. If you have low pressure then it is either the pump or the regulator.

Let me know what the fuel pressure is and we can go from there.

https://www.2carpros.com/articles/how-a-fuel-pump-works

https://www.2carpros.com/articles/how-to-check-fuel-system-pressure-and-regulator
Was this
answer
helpful?
Yes
No
Wednesday, June 12th, 2019 AT 12:42 PM

Please login or register to post a reply.

Recommended Guides