Engine not running properly

Tiny
RICHARD GRAVENELL
  • MEMBER
  • 2011 RENAULT KANGOO
  • 200,000 MILES
Had a new fan fitted now the engine is not running properly. This was done in a local garage.
Sunday, June 27th, 2021 AT 8:26 AM

5 Replies

Tiny
KEN L
  • MASTER CERTIFIED MECHANIC
  • 42,883 POSTS
Misfire? stall? please give us more details on what is going on. This guide may help:

https://www.2carpros.com/articles/engine-misfires-or-runs-rough

Can you please shoot a quick video with your phone so we can see what's going on? that would be great. You can upload it here with your response.
Was this
answer
helpful?
Yes
No
Monday, June 28th, 2021 AT 9:13 AM
Tiny
RICHARD GRAVENELL
  • MEMBER
  • 3 POSTS
Well, it all started with oil leak taken it to garage they said it was cam seal so had all the seals done. New cam and all new belts, took the van out for hour still oil everywhere, sent it back they said it sorted now but fan doesn't work they put new fan in. I took van out again and it’s misfiring, smoking, overheating and running very bad.
Was this
answer
helpful?
Yes
No
Monday, June 28th, 2021 AT 10:59 AM
Tiny
KEN L
  • MASTER CERTIFIED MECHANIC
  • 42,883 POSTS
Did the engine overheat before the repair if so you can have a blown head gasket. To be sure this guide can help us confirm the issue:

https://www.2carpros.com/articles/head-gasket-blown-test

Please run down this guide and report back.
Was this
answer
helpful?
Yes
No
Monday, June 28th, 2021 AT 5:15 PM
Tiny
RICHARD GRAVENELL
  • MEMBER
  • 3 POSTS
No after. Doesn’t lose any fluids.
Was this
answer
helpful?
Yes
No
Monday, June 28th, 2021 AT 9:43 PM
Tiny
KEN L
  • MASTER CERTIFIED MECHANIC
  • 42,883 POSTS
Okay, let's check the compression to make sure the engine is okay. This guide can help:

https://www.2carpros.com/articles/how-to-test-engine-compression

Please run down this guide and report back.
Was this
answer
helpful?
Yes
No
Tuesday, June 29th, 2021 AT 9:02 AM

Please login or register to post a reply.

Sponsored links