2003 Dodge Caravan 2003 Caravan Jerks

Tiny
RONHANOUDI
  • MEMBER
  • 2003 DODGE CARAVAN
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 94,000 MILES
Hi, I have a 2003 Dodge Caravan with 3.8L engine. Recently the vehiicle shook on highway while some noise was coming from the muffler (rear right of car). This lasted for about 20 seconds and the car sounded like it was going to stall.

The car did not stall, and I continued driving for an hour after the incident with no issues. I however did not dare driving over 65MPG as I was not sure if thats what caused the issue. Again, this issue happened 3 days ago and the symptom did not appear again.

Any idea what could have caused this and will it come back again?
Do you
have the same problem?
Yes
No
Saturday, December 19th, 2009 AT 7:19 AM

5 Replies

Tiny
MHPAUTOS
  • EXPERT
HI there, not all that sure what this can be, is the exhaust in good working order? Check that you don't have a muffler collapsing and causing a problem, also just to be on the safe side get a scan done to check for any unresolved fault codes, start here.

Mark (mhpautos)
Was this
answer
helpful?
Yes
No
Saturday, December 19th, 2009 AT 7:39 AM
Tiny
RONHANOUDI
  • MEMBER
Thanks Mark. The muffler might be the cause here.I will have it replaced. In cold weather mufflers do tend to rust at about 100K. Also, you are right. There is a check engine light thats on. I will make sure to take care of it.
Was this
answer
helpful?
Yes
No
Saturday, December 19th, 2009 AT 7:56 AM
Tiny
MHPAUTOS
  • EXPERT
Hi there,
If you get tuck with the codes, post them here for more assistance.

Mark (mhpautos)
Was this
answer
helpful?
Yes
No
-1
Saturday, December 19th, 2009 AT 8:20 AM
Tiny
RONHANOUDI
  • MEMBER
I forgot to mention the car was in cruise control when the issue occured. A mechanic asked me that question and he thinks the cruise control is not correctly working and the jerking noise was that similar to when the car runs out of gas.

He could not find anything else wrong with the car.

Thanks.
Was this
answer
helpful?
Yes
No
Monday, December 28th, 2009 AT 7:29 AM
Tiny
MHPAUTOS
  • EXPERT
Did you get a the codes checked? If it was in cruise, it may be a speed sensor acting up.

Mark (mhpautos)
Was this
answer
helpful?
Yes
No
Monday, December 28th, 2009 AT 8:46 AM

Please login or register to post a reply.

Recommended Guides