Cruise control not working

Tiny
CENTRINO22
  • MEMBER
  • 2009 FORD CROWN VICTORIA
  • 4.6L
  • V8
  • 2WD
  • AUTOMATIC
  • 320,000 MILES
I recently lost steering on the car, I had it towed to Ford. They replaced the steering shaft on recall and also the intermediate shaft. However, when I got the car back the cruise control was not working and I had the ABS and brake lights on on the dash. Tried checking the fuses, no problem there, could they have accidentally done something while replacing the intermediate shaft that would be causing my problems? I had had the car towed to an out of town Ford dealer, when I picked it up I noticed the lights on dash, but only realized the cruise control was not working the next day. I assumed that they just forgot to plug something and I would check, unfortunately I procrastinated and only checked a few weeks later and nothing seems unplugged, but it is too late to go to the dealer claiming it was something they had done.
Do you have any ideas?
Do you
have the same problem?
Yes
No
Saturday, December 2nd, 2017 AT 4:05 PM

1 Reply

Tiny
MHPAUTOS
  • EXPERT
Re-check electrical connections, check for any codes. Not all codes will set a check light. If your brake lights are working, that side of the circuit will be okay. Just go through these points first and let me know what you find. I will see if I have a circuit diagram to look at as well.
Was this
answer
helpful?
Yes
No
Saturday, December 2nd, 2017 AT 4:13 PM

Please login or register to post a reply.

Sponsored links