Crank no spark

Tiny
JLGLZ
  • MEMBER
  • 2003 BMW 745
  • 4.4L
  • V8
  • RWD
  • AUTOMATIC
  • 180,000 MILES
My car is the LI model. I replaced the engine but it will not turn on. It cranks but will not start. I have replaced fuel pump, fuel filter, cam sensors, crank sensor and spark plugs. I sent the DME computer to be checked and all is good. I have a Matco max me scanner and checked. No codes. But I still do not have spark on my coils. Any idea as to what I can check or what can be causing this no spark?
Do you
have the same problem?
Yes
No
Friday, July 7th, 2017 AT 5:39 AM

11 Replies

Tiny
KEN
  • ADMIN
Hello,

It sounds like you have a bad crankshaft angle sensor but to confirm please take a look at these guides to help us in the right direction.

https://www.2carpros.com/articles/car-cranks-but-wont-start

and

https://www.2carpros.com/articles/how-to-test-an-ignition-system

and

https://www.2carpros.com/articles/checking-a-service-engine-soon-or-check-engine-light-on-or-flashing

Here are some diagram (below) that shows where it is on your car.

Please run some tests and get back to us we are interested to see what it is.

Cheers, Ken
Was this
answer
helpful?
Yes
No
Sunday, July 9th, 2017 AT 12:47 PM
Tiny
JLGLZ
  • MEMBER
Thanks got the car to start. I used my brother's. Matco maxme scanner and reset all codes and reset all values for most valves like the intake and the throttle and. And I reset the software and esw car turned on like new. Crank sensor was good all along it was just a code that it was reading from before I replaces the engine. Again Thank you very much for your help
Was this
answer
helpful?
Yes
No
Friday, July 14th, 2017 AT 5:32 AM
Tiny
KEN
  • ADMIN
Glad you could get it fixed, that kind of problem can be tough. Please use 2CarPros anytime we are here to help

Cheers, Ken
Was this
answer
helpful?
Yes
No
+1
Friday, July 14th, 2017 AT 9:35 AM
Tiny
JLGLZ
  • MEMBER
  • 2003 BMW 745
  • 4.4L
  • V8
  • RWD
  • AUTOMATIC
  • 120,000 MILES
I bought car two months ago. Car turns on but only bank 1 is working. Bank 2 does not, have spark. I have checked fuel pump voltage pressure and relays I checked cam sensor replaced new. Checked cam sensors four replaced new. Checked ignition coils eight replaced new. I replaced all this sensors cause voltmeter was reading bad I thought this might be the problem realized I had a bad voltmeter. I got a Matco Max ME scanner and checked for codes no codes. So while researching I found a site. That said to check wiring issues. So I did got a voltmeter and checked wires all are good I checked the IVM that supplies power to the coils and injectors and all is good. I checked the DME. But found out that I do not have pulse on cylinders five to eight, I have twelve volts on every thing. Just no spark. On those four coils. I guess my question would be; can I assume my DME to be bad or what else can I check for not having spark on four coils?
Was this
answer
helpful?
Yes
No
Friday, July 14th, 2017 AT 9:36 AM (Merged)
Tiny
DOCFIXIT
  • EXPERT
I would agree DME is what signals coil to fire and you have checked voltage feed to effected coils
Was this
answer
helpful?
Yes
No
Friday, July 14th, 2017 AT 9:36 AM (Merged)
Tiny
JLGLZ
  • MEMBER
Is the DME repairable or do I need a new one, and any suggestions as to where I can get one
Was this
answer
helpful?
Yes
No
Friday, July 14th, 2017 AT 9:36 AM (Merged)
Tiny
DOCFIXIT
  • EXPERT
Not repairable salvage may have one but it MUST be exact match. Check on line see you can find a BMW help site ie. Club ect
Was this
answer
helpful?
Yes
No
Friday, July 14th, 2017 AT 9:36 AM (Merged)
Tiny
JLGLZ
  • MEMBER
Ok thanks will do
Was this
answer
helpful?
Yes
No
Friday, July 14th, 2017 AT 9:36 AM (Merged)
Tiny
JLGLZ
  • MEMBER
My 2003 bmw 745li started to over heat I dont have any codes and my fan is turning on very slowly but turns off every so often. When I turn on the car now the fan dosent work. What can I check to discard the fan been bad
Was this
answer
helpful?
Yes
No
Friday, July 14th, 2017 AT 5:25 PM
Tiny
KEN
  • ADMIN
It sounds like it could be a blown head gasket causing the problems.

Here is a guide to confirm,

https://www.2carpros.com/articles/head-gasket-blown-test

Please let us know what happens.

Cheers, Ken
Was this
answer
helpful?
Yes
No
Monday, July 17th, 2017 AT 9:40 AM
Tiny
JLGLZ
  • MEMBER
How do I remove the engine malfunction power reduced message from the dash board and I have codes 279a 2792. But I cant delete them and my car wont start.
Was this
answer
helpful?
Yes
No
Monday, July 17th, 2017 AT 10:12 AM

Please login or register to post a reply.

Recommended Guides