STILL WONT BLOW COLD AIR

1999 Chrysler Sebring

Tiny

modex

February, 24, 2010 AT 7:08 PM

Air Conditioning problem
1999 Chrysler Sebring 6 cyl Front Wheel Drive Automatic

I just filled 134 refrigerant into the low side of my 1999 sebring lxi, and after about 30 minutes, it's still not blowing cold air, and only took in three quarters of the can. Everything is working mechanically, so should I try another can of 134, maybe it's still too low in freon levels? What do you think is wrong. I checked all the fuses, belt, compressor clutch, now what. Could it be the safety switch that cuts the a/c off when the freon is too low activated. If so, can I reset it myself? What's the longest you should wait when filling 134, because I waited 30 minutes? This is all one question, so pick the best answer that fits all descriptions and leads I gave you. What is wrong?

FOUND 6253 RELATED QUESTIONS

No Heat

37 ANSWERS
5 IMAGES

1 Answer

Tiny

caradiodoc

February, 25, 2010 AT 9:13 AM

If the compressor isn't running, use a jumper wire to bypass the low pressure cutout switch.

Put the can of refrigerant in a kettle of hot water. You'll be amazed at how fast it goes in. If you did not start with a totally empty system, there is no way to know how much refrigerant is in the system. Use the sight glass on top of the receiver / drier to watch for bubbles. When the bubbles are gone, the system is full. You can add a few extra ounces without a problem.

Caradiodoc

Please login or register to post a reply.

Cabin Air Filter Replacement Saturn Vue
Cabin Air Filter Replacement Porsche 911
Cabin Air Filter Replacement Chevrolet Tahoe