2000 Chevy Trailblazer Lost all electricail

Tiny
ERIC5101
  • MEMBER
  • 2000 CHEVROLET TRAILBLAZER
  • 6 CYL
  • 4WD
  • AUTOMATIC
  • 132,000 MILES
When I went to start the Blazer I turned the key and all electricail systems died. Now the key won't turn back to a position to remove from switch. What would cause all electrail systems to die at once (battery is good)? What do I look for?
Do you
have the same problem?
Yes
No
Sunday, February 24th, 2008 AT 7:25 AM

8 Replies

Tiny
MASTERTECHTIM
  • MEMBER
The most logical place to look is at the battery. Double check the connections, pos and neg. Remove the cables and check for corrosion. Also double check the charge on the battery. To lose all electrical it pretty much has to be at the battery or the under hood electrical box. See if you have power thgere
Was this
answer
helpful?
Yes
No
Sunday, February 24th, 2008 AT 7:40 AM
Tiny
JACK42
  • MEMBER
Loose/dirty connection at the battery can cause that. Be sure all is clean and tight. If good, go to main power center underhood and verify power is making there. If ok get back to me and we will go from there
Was this
answer
helpful?
Yes
No
Sunday, February 24th, 2008 AT 7:40 AM
Tiny
ERIC5101
  • MEMBER
Battery was check and it is good, however there is a slight discharge when you touch the positive terminal with your hand. A bad battery would not cause the key to refuse to come out of the ignition though - - would it?
Was this
answer
helpful?
Yes
No
Sunday, February 24th, 2008 AT 7:46 AM
Tiny
JACK42
  • MEMBER
Unless the tumbler or something in the column is broken, possibly the ignition switch. Do you have power in the truck?
Was this
answer
helpful?
Yes
No
Sunday, February 24th, 2008 AT 8:03 AM
Tiny
ERIC5101
  • MEMBER
Battery is ok, but there is no power to anything else.
Checked all the fuses and relays I could reach. I did pick up on a real faint (weak) clicking under the dash where I can not get to. Someone asked if the factory installed security system could have malfunctioned. :
Was this
answer
helpful?
Yes
No
Sunday, February 24th, 2008 AT 8:28 AM
Tiny
JACK42
  • MEMBER
Is there any power to the underhood fuse/relay center? Need to start at the battrey and work towards the interior. The alarm wouldnt let it run/start, not power down the entre truck
Was this
answer
helpful?
Yes
No
Monday, February 25th, 2008 AT 7:26 AM
Tiny
ERIC5101
  • MEMBER
I had to give up and let the pros take their turn. Right now they are running test and tracing wiring.
Thanks for all your help.
Was this
answer
helpful?
Yes
No
Tuesday, February 26th, 2008 AT 8:15 AM
Tiny
ERIC5101
  • MEMBER
The Pros are stymied also. Short of pulling the dash off, every possible fuse, relay and module has been tested and retested. They put another battery in just to see and it started reluctanly, however after sitting for two hours the blazer died again. Woul;d I be wrong to suppose that it is not a 'device' problem at all since it would start, but it would be a wiring problem causing a draw in the system that could be 'over ridden' by extra juice.
Was this
answer
helpful?
Yes
No
Tuesday, February 26th, 2008 AT 1:37 PM

Please login or register to post a reply.

Recommended Guides