1991 Chevy S-10 Please Help!

  • 1 POST
  • 1991 CHEVROLET S-10

Engine Performance problem
1991 Chevy S-10 6 cyl Four Wheel Drive Automatic 160000 miles

My dad gave me his truck and before he gave it to me he had new distributor cap and wires, new alternator, always on top of tune-ups and I've since then replaced the serpentine belt and fuel filter. However, ever since I have gotten it the truck has issues with running. When I get in the vehicle to start it, it's hesitant to start kind of like it's not getting gas but if you would wait a minute it would be fine but as soon as you'd put it in gear it would die. I used to be able to get it to go if I pumped the gas peddle and once it went just kept going because if I slowed down it would die. So, I changed the fuel filter thinking that might be it. It would run fine once I got it to go but the other day it took many tries to get it to go and then once I got down the road it still acted up and now I can't get it into gear at all without it cutting off. I've had some friends look at it and they've done all the could but they are stumped. We know the firing order in the new dist. Cap is correct and all but we can't get it running and I'm stranded at my sister's house until I can get it running so I would appreciate help as soon as possible!

Do you
have the same problem?
Thursday, August 14th, 2008 AT 11:54 AM

1 Reply

  • 37 POSTS

Check fuel pressure you might need fuel pump

Was this
Thursday, August 21st, 2008 AT 12:54 PM

Please login or register to post a reply.

Recommended Guides