Temp gauge

Tiny
CRISLEANN2002
  • MEMBER
  • 2005 CHEVROLET MALIBU

temp gauge is not working but the rest of gauges are? Is this a sensor or the actual gauge?
Do you
have the same problem?
Yes
No
Tuesday, June 15th, 2010 AT 6:43 PM

13 Replies

Tiny
TOMSHANTY
  • MEMBER
Sounds like either the coolant temp sensor is bad or the gauge. The manual shows the coolant sensor is what the gauge uses as well as the computer. If it is accompanied b the check engine light I would go after the coolant sensor. This vehicle also had issues with corrosion in the connector for the sensor

Its located in the back of the cylinder head
See the diagram below
Was this
answer
helpful?
Yes
No
Wednesday, June 16th, 2010 AT 1:55 AM
Tiny
SENN
  • MEMBER
  • 2001 CHEVROLET MALIBU
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 118,000 MILES
What does it mean when temperature gauge stops working and check engine light comes on?
Was this
answer
helpful?
Yes
No
Tuesday, November 13th, 2018 AT 6:02 PM (Merged)
Tiny
RASMATAZ
  • MEMBER
Could mean the coolant temperature sensor-get the computer scanned at Autozone its a free service to find out what's causing it to pop the CEL
Was this
answer
helpful?
Yes
No
Tuesday, November 13th, 2018 AT 6:02 PM (Merged)
Tiny
RMESSAMORE
  • MEMBER
  • 2001 CHEVROLET MALIBU
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 130,000 MILES
Hello,

Just recently the temperature gauge in my wifes car stopped working. I checked the owners manuel to see if there was a fuse for the temperature gauge. There was not. All the rest of the gauges are working in the instrument panel. Can you please offer me an suggestions as to why only the temperature gauge just stopped working. I'm asking with the free question because I'm unemployed and low on money. I would greatly appreciate any help you can offer. Thank you very much for your time and assistance.
Was this
answer
helpful?
Yes
No
Tuesday, November 13th, 2018 AT 6:02 PM (Merged)
Tiny
RASMATAZ
  • MEMBER
Do you have a check engine light? Could be the coolant temperature sensor out of calibration -also check the wiring
Was this
answer
helpful?
Yes
No
Tuesday, November 13th, 2018 AT 6:02 PM (Merged)
Tiny
RMESSAMORE
  • MEMBER
There is a check engine light but it has not come on. I also noticed that the electronic engine fan seems to run all the time when the car is running. Could this be connected to the non working temperature gauge some how? Thanks for your earlier quick response.
Was this
answer
helpful?
Yes
No
Tuesday, November 13th, 2018 AT 6:02 PM (Merged)
Tiny
ZORG2000
  • MEMBER
  • 2001 CHEVROLET MALIBU
Engine Cooling problem
2001 Chevy Malibu 6 cyl Front Wheel Drive Automatic 80k miles

Year: 2001
Model: Malibu
Engine Size: 3.1L Sti V6 'Good ol reliable' lol
Auto/Manual: Auto
Mileage: 125,000kms

Hi everyone! First post on this site and I hope theres some people still on this thing. And im sorry but I am going to rant!

I bought this car 9 months ago and it seemed ok (i didnt know much about mech's at the time) lets just say I had no idea of the car being the ultimate lemon in north american (i flushed out that beautiful dexcool in the dark trying to save my gaskets after reading about it lol)

Anyways about 2 months ago whilist on a two hour long journey my temp gauge died, didnt make a sound. Just stoped, stuck at stone cold. On a hot day.

Engine check light goes on next day whilist making the hours back home and this makes me nervous as I had overheating prblms on the really hot days when stuck in slow traffic and my cooling system would bleed out the surge tank saftey hose.

Ok so I read a haynes manual and it tells me that the 'Coolant temperature sensor' is responsible for the HUD gauge and for the ECM and tells the ECM when to turn on my fans. Big job for a sensor.

I bought a new sensor and just before I change it. ITS WORKING?
But not for long. It dies in a couple days again

So screw it, I got a deep socket and changed the sensor myself (in the canadian tire parking lot lol). Turn the car on and the gauge works for like a second barely making it a quater way up. And drops and dies again. Engine check light still on even after I unplugged negative battery cable for a few mins.
This is funny overheating in summer and now underheating in winter sigh*

So thats my problem
-Temp Gauge no worky
-Bad (meaning worse) gas milage
-Heater works but barely
-Engine fans always on

any ideas people? Help woud be very much appreciated
Was this
answer
helpful?
Yes
No
Tuesday, November 13th, 2018 AT 6:02 PM (Merged)
Tiny
SCOTTY DEE
  • MEMBER
Is there a leak in the cooling system? Have you had it scanned for codes?
Was this
answer
helpful?
Yes
No
Tuesday, November 13th, 2018 AT 6:02 PM (Merged)
Tiny
JIM H
  • MEMBER
  • 2001 CHEVROLET MALIBU
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 145,000 MILES
Temp gauge just stopped working
Was this
answer
helpful?
Yes
No
Tuesday, November 13th, 2018 AT 6:03 PM (Merged)
Tiny
JACOBANDNICKOLAS
  • EXPERT
Check the temp sending unit.
Was this
answer
helpful?
Yes
No
Tuesday, November 13th, 2018 AT 6:03 PM (Merged)
Tiny
TAMEOR
  • MEMBER
  • 2001 CHEVROLET MALIBU
  • 140 MILES
The auto headlights and the gas gauge and temp gauge power windows and heater controls have stopped working tried everything
Was this
answer
helpful?
Yes
No
Tuesday, November 13th, 2018 AT 6:03 PM (Merged)
Tiny
ASEMASTER6371
  • EXPERT
The common denominator is the bcm or body control module. Have it scanned for codes.

What is everything you checked?

Roy
Was this
answer
helpful?
Yes
No
Tuesday, November 13th, 2018 AT 6:03 PM (Merged)
Tiny
TAMEOR
  • MEMBER
Fuses, relays wires they all checked out fine
Was this
answer
helpful?
Yes
No
Tuesday, November 13th, 2018 AT 6:03 PM (Merged)

Please login or register to post a reply.

Recommended Guides