Engine stops

Tiny
POINCE
  • MEMBER
  • 2001 BUICK ROADMASTER
FROM IDLING MY ENGINE STOPS WHEN PUT INTO GEAR.

IF I ACCELERATE THE ENGINE, IT WORKS BETTER BUT IT ISN T APPROPIATE FOR THE AUTOMATIC GEARBOX

I already changed those items

- manifold Absolute pressure Sensor ( MAP)
- Throttle position sensor ( TPS )
- Positive crankcase ventilation ( PCV valve )
- vehicle Speed sensor ( VSS )
- E.G.R valve
- E.G.R solenoid
- Idle Air control ( IAC valve )
- Oxygen sensor


It still doesn't work

The gearbox is a Hydra - matic 4L60 ( THM700-R4 )

if anyone could help, Thanks
Thursday, April 17th, 2008 AT 10:02 AM

27 Replies

Tiny
JACOBANDNICKOLAS
  • MECHANIC
  • 108,145 POSTS
Hi:
Check the power brake booster. Remove the vacuum line and plug it. Check if the engine dies when you hit the brakes. If it doesn't check the hose for damage or the booster. Replace as needed. NOTE: You will have no power assist with this disconnect, so don't drive the car until repairs are made.

this guide will help

https://www.2carpros.com/articles/engine-stalls

Please run down this guide and report back.
Was this
answer
helpful?
Yes
No
Monday, November 17th, 2008 AT 10:45 AM
Tiny
TURBOJAY
  • MEMBER
  • 1 POST
Thank you for this post I had this problem and had to fix a vacuum leak thanks to the guide. All fixed I love this site.
Was this
answer
helpful?
Yes
No
Wednesday, November 13th, 2019 AT 6:48 PM
Tiny
RONALDTUBBS
  • MEMBER
  • 4 POSTS
  • 1996 BUICK ROADMASTER
Electrical problem
1996 Buick Roadmaster V8 Two Wheel Drive Automatic 210k miles

Hello,
I am looking for help with a problem where my vehicle simple shuts down as I am driving down the road. No coughs or sputters it just stops running. When this happens I have no spark. If the engine is not quite up to operating temperature it will often restart and let me drive alittle farther. Then it will shut down again. I can only get about 6 or 7 miles from home before this occurs. It has gotten intermitently worse as time goes on. I have replaced the fuel pump and harness in the tank, the fuel filter, the ignition module, the coil, and the crankshaft position sensor. All of this within the last two weeks and the condition continues to worsen. I have the LT1 5.7L engine. It runs fine when it is running. Any help will be appreciated.
Thank-you,
Ron
Was this
answer
helpful?
Yes
No
Wednesday, November 13th, 2019 AT 6:49 PM (Merged)
Tiny
RONALDTUBBS
  • MEMBER
  • 4 POSTS
The distributor and cap were recently replaced new.
It appears that there is no spark from the coil
Was this
answer
helpful?
Yes
No
Wednesday, November 13th, 2019 AT 6:50 PM (Merged)
Tiny
JDL
  • MECHANIC
  • 16,098 POSTS
Check the primary circuits at the coil.
Was this
answer
helpful?
Yes
No
Wednesday, November 13th, 2019 AT 6:50 PM (Merged)
Tiny
RONALDTUBBS
  • MEMBER
  • 4 POSTS
Hello again,

When the car will not start there is no hot to the coil.
Was this
answer
helpful?
Yes
No
+1
Wednesday, November 13th, 2019 AT 6:50 PM (Merged)
Tiny
JDL
  • MECHANIC
  • 16,098 POSTS
Check the pcm/ign fuse, I believe it is in the underhood fuse box, 10 amp fuse. The voltage to the fuse is ignition feed, goes hot when you turn on the key. Could be the ignition switch, the wiring circuit to or from the switch. The circuit from the fuse to the coil. Check for voltage at the fuse circuit first.
Was this
answer
helpful?
Yes
No
Wednesday, November 13th, 2019 AT 6:50 PM (Merged)
Tiny
USECOM
  • MEMBER
  • 1 POST
  • 1995 BUICK ROADMASTER
I have a 95 Buick Roadmaster with 130,000 miles 5.7 ltr v-8 / LT1 I replaced the Opti, coil wires, plugs, altenator, water pump about 2 years ago and I have regular oil changes including a recent fuel filter change. Tranny filter and flush coolant flush all within the past year.

The car stalls usually in Park at idle or in drive at stop light. It acts like the idle is low or to low and then it stalls. Restarts with no problems. Idle RPM is 575 to 500 RPM. It also stutters and shudders off the line and is made worse if I gear down.

I have a XRay 6000 and I have cleared a code in history related to the MAF and it keeps coming back in history but not current codes.

The exhaust sound is vey rough, kinda a puh puh puh sound, but listening to just the engine; it is running smooth.

Totally lost but I have taken it to 2 mechanics and got it needs a new Opti and the other said new Cats and and O2 sensors and I talked to another and he suggested a speed sensor or the IAC valve may need replaced.

Any idea on where to start?
Was this
answer
helpful?
Yes
No
Wednesday, November 13th, 2019 AT 6:50 PM (Merged)
Tiny
DONALDP
  • MEMBER
  • 1 POST
Was this
answer
helpful?
Yes
No
-2
Wednesday, November 13th, 2019 AT 6:50 PM (Merged)
Tiny
JCHEVIS
  • MEMBER
  • 1 POST
  • 1995 BUICK ROADMASTER
  • V8
  • 4WD
  • AUTOMATIC
  • 106,000 MILES
My car cranks and seems like it stutters for gas, then dies. And even when it stays cranked, when I touch the gas or throw it in drive or reverse it cuts off.
Was this
answer
helpful?
Yes
No
Wednesday, November 13th, 2019 AT 6:50 PM (Merged)
Tiny
RHALL77
  • MECHANIC
  • 3,361 POSTS
I would check fuel pressure and the fuel filter. If those check out all right check the distrubitor. What engine does it have? Have you have a tune up lately, is the service engine soon light on?
Was this
answer
helpful?
Yes
No
-1
Wednesday, November 13th, 2019 AT 6:50 PM (Merged)
Tiny
JEREMIAH1980
  • MEMBER
  • 1 POST
  • 1995 BUICK ROADMASTER
1995 Buick Roadmaster Automatic

what does it mean when the car stops running even though it has gas but when I put more gas it starts up immediately until I run the gas halfway again and it stalls out is there a such thing as bad gas?
Was this
answer
helpful?
Yes
No
Wednesday, November 13th, 2019 AT 6:50 PM (Merged)
Tiny
MICHAEL7500
  • MEMBER
  • 25 POSTS
I'm no expert but I believe that small amounts of dirt and other contaminants can over time build up in the bottom of your gas tank which would probably stall your car.

It's also possible that water got in your gas tank because water is more dense than gas so the gas will stay on top so maybe when you have a half tank left you really have a half tank of WATER. Hope that helps.
Was this
answer
helpful?
Yes
No
Wednesday, November 13th, 2019 AT 6:50 PM (Merged)
Tiny
CITYILU5
  • MEMBER
  • 3 POSTS
  • 1993 BUICK ROADMASTER
  • V8
  • 2WD
  • AUTOMATIC
  • 130,000 MILES
Just replaced coil, rotor, module, cap and wires and my 93 roadmaster engine died. Before it stop running I noticed that the voltage meter would drop from 15 to 13 on the meter. But everything worked
Was this
answer
helpful?
Yes
No
Wednesday, November 13th, 2019 AT 6:50 PM (Merged)
Tiny
BLUELIGHTNIN6
  • MECHANIC
  • 16,542 POSTS
Does it try to crank over at all or getting nothing from turning key?
Was this
answer
helpful?
Yes
No
Wednesday, November 13th, 2019 AT 6:50 PM (Merged)
Tiny
CITYILU5
  • MEMBER
  • 3 POSTS
Yes it turns over but will not crank
Was this
answer
helpful?
Yes
No
Wednesday, November 13th, 2019 AT 6:50 PM (Merged)
Tiny
BLUELIGHTNIN6
  • MECHANIC
  • 16,542 POSTS
Will have to test the fuel pressure to see if getting proper fuel and make sure spark plugs are getting healthy blue spark
Was this
answer
helpful?
Yes
No
Wednesday, November 13th, 2019 AT 6:50 PM (Merged)
Tiny
CITYILU5
  • MEMBER
  • 3 POSTS
The fuel pump is working properly. What's next?
Was this
answer
helpful?
Yes
No
Wednesday, November 13th, 2019 AT 6:50 PM (Merged)
Tiny
BLUELIGHTNIN6
  • MECHANIC
  • 16,542 POSTS
Plugs getting good spark? If so then test compression at cylinders.
Was this
answer
helpful?
Yes
No
Wednesday, November 13th, 2019 AT 6:50 PM (Merged)
Tiny
TEQUILLABRIGGS
  • MEMBER
  • 1 POST
  • 1993 BUICK ROADMASTER
  • V8
  • 2WD
  • AUTOMATIC
  • 121,000 MILES
I have a 93 Roadmaster. Yesterday while parked at the store my car cut off. I sarted itt back but it shook a little. I got out and notice a smell like something was burning but my vehicle was not running hot. I took the car home and noticed my battery voltage jumped to 19 volts. In the passed I have noticed that my Infl rest light flashed on causing my car to act as if it wanted to stall when I pressed the brakes. Could the two problems be related
Was this
answer
helpful?
Yes
No
Wednesday, November 13th, 2019 AT 6:50 PM (Merged)

Please login or register to post a reply.

Sponsored links