1995 BMW 525i



August, 31, 2010 AT 3:13 PM

1995 BMW 525i 6 cyl Two Wheel Drive Automatic 150000 miles

I replaced the fuel pump and the sending unit on this car. I am positive that the new pump works. I am getting no power to the fuel pump fuse. After applying power to the fuse directly, and verifying that the pump activates, I am getting no fuel out of the tank. The car was running when I began this project, but would fail to start 6 out of ten times after turning off the engine. When this occurred, I would pop the trunk and hit the trunk with my hand where the fuel sending unit was located. The car would start immediately, running rough until I got the car rpm's up a bit, and then smooth out. Without jumped power to the fuel pump fuse, there was power to the relay, but not the fuel pump fuse. With the relay removed, and then jumping the terminals where the fuel pump relay was located, I would get power to the fuse, but it still would not start. I traced the power under these conditions, and had power to the back seat where the fuel pump wires ran through the body, and to the plug for the fuel sending unit. No power at the plug. So I only get power to the plug at the sending unit if I jump power at the fuel pump fuse, but still get no fuel out of the sending unit. No check engine light comes on at any time, the fusible links are fine. Could the computer be telling the car not to start? Could I have a bad ground wire attached to the tank preventing the fuel from comming out of the sending unit even after applying direct power to the pump. I desperately need more than a short answer. Even some specific steps or troubleshooting steps would be helpful. I had a certified mechanic with me throughout all of this, however, he is primarily a diesel mechanic, and we are working only with jumper wires, a test light, and volt meter. He has pulled the pump and sending unit out of the car over and over as we followed leads and tips given to us over the phone from repair shops. What do you think is creating this issue given all the information above. What are the proper troubleshooting steps? My technician friend is still suspicious of the relay, the relay block, the tank grounds, and the idea that the computer is controlling the pressure regulator, which is part of the sending unit assembly, thus keeping the operating fuel pump, that is in a tank with plenty of gas from pumping the fuel.


4 Answers


Dr. Hagerty

August, 31, 2010 AT 3:39 PM

OK, the Doctor is in. We can begin with the proper identification of the car. Resend the last 7 of the VIN.



August, 31, 2010 AT 5:21 PM

Ok, the last seven of the v.I.N. Are. GK87043


Dr. Hagerty

September, 1, 2010 AT 6:16 AM

Replacement of the main and fuel pump relays are certainly in order, they do have failure as a possibility. The power flows through the fuel pump relay, then fuse 29 then, then to the fuel pump over the green/violet wire. The computer is not in control of the pressure regulator, and it is not part of the sending unit, the fuel pressure regulator is at the fuel rail. If you power the pump at the green/violet wire, it will produce fuel under pressure or there is something wrong with the pump, plain and simple. Is the fuel filter clogged? Is the pump in its holder in the fuel tank? Is it immersed in fuel? Does the pump draw 4-6 amps when running? Are you sure the pump runs?


Joe Kearney

May, 23, 2014 AT 11:57 AM

I just solved this problem. I put in a new fuel pump, the pump would run, but no fuel out of the fuel line.

I don't know why it isn't emphasized in Bently or forums, but reverse polarity on the wiring at the pump will make it run backwards.

Check the polarity, make sure + is connected to + and - is connected to -.

Once I reversed the polarity, fuel gushed from the line to the fuel rail.

Please login or register to post a reply.

Fuel Pump Replacement Ford Mustang
Fuel Pump Replacement
Fuel Pump Replacement Done Right
Fuel Pump Pressure Test
Fuel Pump Test Chevy Tahoe