1992 BMW 525i Won't start after replacing fuel pump and fue

Tiny
TRNRTERI
  • MEMBER
  • 1992 BMW 525I
  • 6 CYL
  • 2WD
  • MANUAL
  • 24,500 MILES
Just replaced the fuel pump and the fuel filter. All electrics check out ok and has fuel pressure and 1/2 tank of fuel. Any suggestions?
Do you
have the same problem?
Yes
No
Saturday, February 21st, 2009 AT 7:33 PM

3 Replies

Tiny
DR. HAGERTY
  • MEMBER
Was there a reason the pump and filter were changed? You mention " all electrics check out OK", what does this mean?
If there is fuel pressure at the injector rail and there is spark, then it should run, something is missing, lets get to what it is, check for spark and see if there is an injector signal.
Was this
answer
helpful?
Yes
No
Saturday, February 21st, 2009 AT 10:35 PM
Tiny
TRNRTERI
  • MEMBER
Yes. The car quit, checked out fuel pump as per Bently manual, that was it. Car ran perfectly before pump died. Replaced fuel filter as well, heard it was good to do that when replacing a pump. Performed all the diognostics as per manual. Crank sensor is working, there is fuel to the rails, and spark. Fuel pump relay, fuel pressure regulator and the new pump all working. Were wondering now if we need to reset some code. After a stomp test the only code that we get is 1261, and it just keeps repeating that code, but when we check the fuel pump relay control, its fine, no short or other wiring problems.
Was this
answer
helpful?
Yes
No
Sunday, February 22nd, 2009 AT 9:51 AM
Tiny
DR. HAGERTY
  • MEMBER
Did you check for an injector signal? A small light bulb or a noid light will work here. One side of the injector plug will be battery voltage and the other side is the DME bringing it to ground for however many milliseconds it wants to inject fuel. If there is spark and fuel and compression, it will run, one of those three is missing.
Was this
answer
helpful?
Yes
No
Sunday, February 22nd, 2009 AT 10:10 AM

Please login or register to post a reply.

Recommended Guides