GUAGE CLUSTER NOT WORKING. I HAVE THE TACH ABD ILLUMINATION AND THATS IT.

2008 Dodge Ram

Tiny

pri_i_oh

September, 27, 2012 AT 6:25 PM

I have 1998 dodge ram 3/4 ton with the 24 valve cummins with 292,301 miles and my guage cluster doesnt work. It lights up and I have my tach and thats it. No other guages work. Ive been chasing wires with wiring diagrams so find broken wires and I havent found any. Im thinking the ECM (the one on the driver side of the block might be the culprit but im not positive and dont want to spend a bunch more money without finding out for sure

7 Answers

Tiny

ASEMaster6371

September, 27, 2012 AT 6:27 PM

I would verify power to the cluster. If you have it, then the cluster is most likely the failure, not the pcm
Roy

Tiny

pri_i_oh

September, 27, 2012 AT 6:45 PM

I did verify the cluster works. I did the "cluster check" and I put it in my buddys truck that has the same exact truck. The reason im thinking ECM is because thats about the only thing I havent been able to test or check

Tiny

ASEMaster6371

September, 27, 2012 AT 7:20 PM

Do you have acess to a scan tool?

Roy

Tiny

pri_i_oh

September, 27, 2012 AT 7:26 PM

Yes. The only code I get is a "bus error" or something along those lines.

Tiny

ASEMaster6371

September, 27, 2012 AT 7:43 PM

Not a code reader, an actual scan tool

Roy

Tiny

pri_i_oh

September, 27, 2012 AT 8:15 PM

I had ot read at the dealership but they had problems getting it to work because of the bus error

Tiny

pri_i_oh

September, 29, 2012 AT 3:57 PM

I am soooo sorry. Not sure of it makes a difference or not but its a 1998 not a 2008

Please login or register to post a reply.

Cabin Air Filter Replacement
Cabin Air Filter Replacement
Dynamat Door Installation
Cabin Air Filter Replacement Porsche 911
Blend Door Actuator Replacement
Door Panel Removal & Speaker Replacement