Radio not working

Tiny
FOX06TSX
  • MEMBER
  • 2006 ACURA TSX
  • 2.4L
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 310,000 MILES
So I've owned my car for a couple years now, recently I started slowly modding it, mostly just small stuff, staying on the budget side. About a year ago, I decided to swap all my speakers out for better ones. I took the radio out to see what it would take to put in an aftermarket head unit. Ever since I took it out and put it back in, the radio worked fine, but the climate control button lights didn't work, the clock stopped showing time, and the tuner knob stopped working. I was fine with that, it was a bit of a pain, but I could live with it. I'm a college student, and it still gets me front point A to point B and the radio would still keep me company.

Well I installed a sub woofer recently, it's worked fine for a few months, but I had an awful rattle in the trunk area. So tonight I went to my buddy's house to figure it out. Now my buddy used to install sound systems professionally, and I know a bit about electronics but more about engines. We fixed the sub issues, and took off the rear shelf to dynomat everything. We unhooked the battery so we could get the airbag covers off, better safe than sorry IMO. Now, we get to my real issues. So now the radio will not turn on. We checked every single fuse in the car, tested every single wire in the radio connector, it won't even show the code symbol. So I took the radio back out and we looked over the motherboard, there was no burned circuitry, and none of the capacitors appeared burned out. BTW, it seems like every time I remove the radio, something else bad happens. Because not only does the radio not work, not the dang climate screen is so dim, it's almost impossible to see. I checked the radio to see if the back light had just went out, but no, it just doesn't work. We did everything we could think of electronically, we checked wiring diagrams, tested connections, replaced fuses, disconnected and reconnected the speaker wires. We are both completely out of ideas. We spent four hours alone, troubleshooting this and came up with nothing.
Do you
have the same problem?
Yes
No
Tuesday, May 21st, 2019 AT 1:29 AM

1 Reply

Tiny
KEN
  • ADMIN
I have seen the steering wheel clock spring cause this issue. here is a guide to help you confirm the issue by testing the connections and the wiring diagrams below to help see which wires to steering through the clock spring:

https://www.2carpros.com/articles/how-to-check-wiring

Check out the diagrams (below). Please let us know what you find. We are interested to see what it is.
Was this
answer
helpful?
Yes
No
Thursday, May 23rd, 2019 AT 1:09 PM

Please login or register to post a reply.

Recommended Guides