No Start No Spark

Tiny
RANGOODO
  • 2006 CHEVROLET AVEO
  • 4 CYL
  • FWD
  • AUTOMATIC

2006 Chevy Aveo LS 1.6L no spark. Has new coil pack. Turn over fine. No Codes. Timing Belt news. Crank and cam both turning. Has Fuel.

Do you
have the same problem?
Yes
No
Monday, August 22nd, 2011 AT 8:24 PM

25 Replies

Tiny
2CARPROS KEN
  • ADMIN
  • 8,641 POSTS

Hello,

This sounds like the crankshaft angle sensor has gone out and need replacement, here is a guide and a diagram to help you get the job done.

https://www.2carpros.com/articles/crankshaft-angle-sensor-replacement

Please let us know if you need anything else to get the problem fixed.

Best, Ken

Was this
answer
helpful?
Yes
No
+1
Tuesday, April 18th, 2017 AT 4:10 PM
Tiny
LUZ LORENZO
  • 2006 CHEVROLET AVEO

Electrical problem
2006 Chevy Aveo 4 cyl Front Wheel Drive Automatic 67100 miles

The car turns over and I have 12v on the battery. I think that it will not start because the fuel punp may be bad. I checked the fuse for the fuel punp and dc volts are going thru it and it was good. The relay for the fuel pump, tested good. I ran a condenuity check through the fuel pump and it check ok. It read about 230-280 kilo owms of resistance. However the fuel pump may be jammed some other way. Or maybe its something else all together. Is there like a module on these cars, kind of like the 90's Fords? What do I need to do to repair this problem?

Was this
answer
helpful?
Yes
No
Tuesday, April 18th, 2017 AT 4:31 PM (Merged)
Tiny
JACK42
  • MEMBER

Have you tested for power at the fuel pump, or at least at the wiring as close to the pump as possible? Does the relay click on when thekey is first turned on? If relay clicks and there is power at the rear of the vehicle it may be the pump is bad. Try spraying a littel carb cleaner into theintake to see if it will start, if so you know it is a fuel issue

Was this
answer
helpful?
Yes
No
+1
Tuesday, April 18th, 2017 AT 4:31 PM (Merged)
Tiny
KYLLIECREELUNDY
  • 2006 CHEVROLET AVEO
  • 1.6L
  • 4WD
  • AUTOMATIC
  • 118,000 MILES

I completely fried my battery by reversing polarity during a jump. I was able to replace my battery with a brand new one, I was able to start it and drive it home with shortages from the radio. My alternator was replaced awhile ago so its far from being an old crummy one. But now when I start my car it does not start. It cranks but that's all the action that is coming from it. I don't have a ton of money for this car, so I'm trying to find the cheapest route. My battery fuse is unlike my other fuses and is all wires. But from what I can see everything looks good on it. I need to know what I can do myself before taking it and paying tons of money just to find out a fuse is blown. I would also like to check the fuses first before going onto bigger things like my alternator or radio.

Was this
answer
helpful?
Yes
No
Tuesday, April 18th, 2017 AT 4:31 PM (Merged)
Tiny
HMAC300
  • EXPERT
  • 49,708 POSTS

Try resetting security system because battery was disconnected.

Was this
answer
helpful?
Yes
No
Tuesday, April 18th, 2017 AT 4:31 PM (Merged)
Tiny
NICRIC53
  • 2005 CHEVROLET AVEO
  • 4 CYL
  • FWD
  • AUTOMATIC
  • 125,000 MILES

2005 aveo will start today drove about45 miles to work sit all day got out would not start after an hour finally started got home started right back up then would not start for two days then it started right up runs great when its start when it don;t acts like it wet and tries but won't just keep trying. Why won't it start?

Was this
answer
helpful?
Yes
No
Tuesday, April 18th, 2017 AT 4:31 PM (Merged)
Tiny
RASMATAZ
  • MEMBER

Do below to determine whether it's fuel or spark issue:

Get a helper disconnect a sparkplug wire or 2 and ground it to the engine at least 3/16 away from ground -have helper crank engine over-do you have a snapping blue spark? If so-you have a fuel related problem, Do you hear the fuel pump come On when you turn key on? If not check fuel pump fuse and fuel pump relay if so, check the fuel pressure to rule out the fuel filter/fuel pump/pressure regulator and listen to the injector/s are they pulsing or hook up a noid light. No snapping blue spark continue to troubleshoot the ignition system-power input to the coil/coil packs, coil's resistances, distributor pick-up coil, ignition control module, cam and crank sensors and computer Note: If it doesn't apply disregard it.

Was this
answer
helpful?
Yes
No
Tuesday, April 18th, 2017 AT 4:31 PM (Merged)
Tiny
DEMONEY1959
  • 2005 CHEVROLET AVEO

Engine Mechanical problem
2005 Chevy Aveo 4 cyl Front Wheel Drive Automatic 7300.0 miles

the car stop on the freeway while driving, when trying to start in makes a sound like it wants to start but will not. We check the starter, and was wondering if it could be the timing belt

Was this
answer
helpful?
Yes
No
Tuesday, April 18th, 2017 AT 4:31 PM (Merged)
Tiny
RASMATAZ
  • MEMBER

Open the front cover and inspect the belt if okay do below to find out what's missing fuel or spark?

Get a carb cleaner and spray into the carb or the throttle body on an EFI. Did it start and die? If not disconnect a sparkplug wire or 2 and ground it to the engine -have helper crank engine over-do you have a snapping blue spark? If so-you have a fuel problem, check the fuel pressure to rule out the fuel pump/pressure regulator and listen to the injector/s are they pulsing or hook up a noid light.

If both fuel and spark is present-check the valve and ignition timing, this will lead you to problems with compression and valves opening and closing at the wrong time

Was this
answer
helpful?
Yes
No
+1
Tuesday, April 18th, 2017 AT 4:31 PM (Merged)
Tiny
STEFANIE_55
  • 2005 CHEVROLET AVEO

Engine Mechanical problem
2005 Chevy Aveo 4 cyl Manual

Hi, I just put a new engine in my car. But after we connected everything back up and tried starting it, it wont start. The starter is working when I try and start it and there is fuel going to the engine, but it seems like its not igniting. What could be the problem?

Was this
answer
helpful?
Yes
No
Tuesday, April 18th, 2017 AT 4:31 PM (Merged)
Tiny
RASMATAZ
  • MEMBER

Do below

Get a helper disconnect a sparkplug wire or 2 and ground it to the engine atleast 3/16 away from ground-have helper crank engine over-do you have a snapping blue spark? If so-you have a fuel related problem, check the fuel pressure to rule out the fuel filter/fuel pump/pressure regulator and listen to the injector/s are they pulsing or hook up a noid light. No snapping blue spark continue to troubleshoot the ignition system-power input to the coil/coil packs, coil's resistances, cap and rotor, distributor pick-up coil, ignition control module, cam and crank sensors and computer Note: If it doesn't apply disregard it and keep testing

Was this
answer
helpful?
Yes
No
Tuesday, April 18th, 2017 AT 4:31 PM (Merged)
Tiny
BARRY ROGERS
  • 2005 CHEVROLET AVEO
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 93,196 MILES

My chev 2005 aveo will not start
in park but will in neutral

Was this
answer
helpful?
Yes
No
Tuesday, April 18th, 2017 AT 4:31 PM (Merged)
Tiny
DOCFIXIT
  • EXPERT
  • 18,993 POSTS

Neutral safety switch faulty or needs adjustment

Was this
answer
helpful?
Yes
No
Tuesday, April 18th, 2017 AT 4:31 PM (Merged)
Tiny
LUIS17
  • 2007 CHEVROLET AVEO
  • 60,000 MILES

I washed my engineon my car I left thehood open to dry it for about a half hour. I went to work and came back. Check engine light went on while I was driving to work and coming back. The next morning I tryed to start my car but I won't start everything electrical turns on but it seems like the fuel is not being delivered so the enginecan start. Help please?

Was this
answer
helpful?
Yes
No
Tuesday, April 18th, 2017 AT 4:32 PM (Merged)
Tiny
FIXITMR
  • MEMBER

If system does not detect spark it wont deliver fuel is usually the case. You got somethin wet that's defeating the startup. I did this once with a car and had to disassemble ignition unit and dry out with hair dryer.

Was this
answer
helpful?
Yes
No
Tuesday, April 18th, 2017 AT 4:32 PM (Merged)
Tiny
LUIS17
  • MEMBER

How can I take that appart? And where is the ignition system?

Was this
answer
helpful?
Yes
No
Tuesday, April 18th, 2017 AT 4:32 PM (Merged)
Tiny
FIXITMR
  • MEMBER

Find out if you have spark.

Was this
answer
helpful?
Yes
No
-2
Tuesday, April 18th, 2017 AT 4:32 PM (Merged)
Tiny
COMPUTERTECH90
  • MEMBER

Check to see if their is a valve leak on or around your spark plugs, also look for any sitting water anywhere.

Was this
answer
helpful?
Yes
No
Tuesday, April 18th, 2017 AT 4:32 PM (Merged)
Tiny
CADIEMAN
  • MEMBER

If you have a dist. Cap remove and spray out with wd40 and dry. It wet in their.

Was this
answer
helpful?
Yes
No
Tuesday, April 18th, 2017 AT 4:32 PM (Merged)
Tiny
FIXITMR
  • MEMBER

Coils and module are unitized. If you could read codes that might help. Nice to own an inexpensive code reader just for such situations. Did you check for spark? Is it possible it broke the timing belt? Does crankover sound flat/even like no resistance from compression?

Was this
answer
helpful?
Yes
No
Tuesday, April 18th, 2017 AT 4:32 PM (Merged)

Please login or register to post a reply.

Related Engine Not Starting Content

Engine Will Not Start
VIDEO

Recommended guides