2003 SAFARI VAN WONT START, BUT IT TURNS OVER

  • Tiny
  • Mark Stevenson
  • 2003 GMC SAFARI
  • 100,000 MILES

I took the kids to school and no problems. Three hours later and it wont start. It seems like its not getting fuel

Do you
have the same problem?
Yes
No
Tuesday, February 28th, 2012 AT 7:37 PM

15 Replies

  • Tiny
  • Saturntech9
  • EXPERT
  • 30,253 POSTS

Is the security light on solid or flashing?

Was this
answer
helpful?
Yes
No
Tuesday, February 28th, 2012 AT 7:43 PM
  • Tiny
  • Mark Stevenson
  • MEMBER

Flashing at first, then it turns off, My check engine light just now turned on. What do you think it might be

Was this
answer
helpful?
Yes
No
Tuesday, February 28th, 2012 AT 8:00 PM
  • Tiny
  • Saturntech9
  • EXPERT
  • 30,253 POSTS

If the engine isnt running the check engine light should be on. So the security light is flashing?If it is it will disable your fuel injectors not allowing fuel to the engine.

Was this
answer
helpful?
Yes
No
Wednesday, February 29th, 2012 AT 2:05 AM
  • Tiny
  • Mark Stevenson
  • MEMBER

So what do I do now. I just replaced the fuel filter and I've never seen fuel so dark. It was very hard to blow through the filter. How do I get my vehicle running now.

Was this
answer
helpful?
Yes
No
Wednesday, February 29th, 2012 AT 2:44 AM
  • Tiny
  • Cadieman
  • MEMBER

Does it try to start with spray?

Was this
answer
helpful?
Yes
No
Wednesday, February 29th, 2012 AT 2:53 AM
  • Tiny
  • Saturntech9
  • EXPERT
  • 30,253 POSTS

If that was the first time the fuel filter was changed then that would explain the dark fuel and restricted filter. See if you have spark and see what the actual fuel pressure is. Also see if you are getting a injector pluse you would unplug the injectors and plug in a noid light where the injector went. Then crank the engine over and see if the light flashes. The light should flash while cranking it shouldnt stay on solid. Check all the injector connectors.

Was this
answer
helpful?
Yes
No
Wednesday, February 29th, 2012 AT 3:11 AM
  • Tiny
  • Mark Stevenson
  • MEMBER

Thanks for the info, I havent tried starting it with spray yet, but I will. If not I will do everything else. Thanks for the help. I hope it will start with the spray.

Was this
answer
helpful?
Yes
No
Wednesday, February 29th, 2012 AT 5:38 PM
  • Tiny
  • Saturntech9
  • EXPERT
  • 30,253 POSTS

Keep me posted on what you find.

Was this
answer
helpful?
Yes
No
Wednesday, February 29th, 2012 AT 5:41 PM
  • Tiny
  • Mark Stevenson
  • MEMBER

Thanks for the help. I just got the van to start using starting fluid. But it runs for a few seconds then dies. The check engine light has turned off. I just dont think it is getting fuel now. Could a fuse be the problem?

Was this
answer
helpful?
Yes
No
Thursday, March 1st, 2012 AT 12:36 AM
  • Tiny
  • Cadieman
  • MEMBER

Check power to the injector fuse and fuel pump fuse on the fuse panel under below the glove box. That they show good and that u hear the pump turn on.[

Was this
answer
helpful?
Yes
No
Thursday, March 1st, 2012 AT 2:02 AM

Please login or register to post a reply.

Other Engine No Start Questions