Does not start sometimes

Tiny
ALEX PROPMAN
  • 2003 CHEVROLET SUBURBAN
  • 150,000 MILES

My 2003 Chevy Suburban does not start sometime. I was told that the factory alarm is responsible for this. It does not reset sometimes and prevents gas from being pumped into the engine. I took it to the dealer they changed the passlock sensor still have the problem?

I wait 10 mins sometimes it starts. Sometimes I have to wait the whole night.

Nice site :-)

Do you
have the same problem?
Yes
No
Thursday, February 16th, 2012 AT 1:57 AM

48 Replies

Tiny
2CARPROS KEN
  • ADMIN
  • 10,929 POSTS

If the security light is flashing then the alarm is stopping it from starting. If the light is not flashing then I would say it is the fuel pump that is causing the problem. Here are a few guides that we help us get started finding out the problem.

https://www.2carpros.com/articles/how-to-check-fuel-system-pressure-and-regulator

and

https://www.2carpros.com/articles/car-cranks-but-wont-start

and

https://www.2carpros.com/articles/how-to-reset-a-security-system

Please run some tests and get back to us so we can keep helping you.

Cheers, Ken

Was this
answer
helpful?
Yes
No
Thursday, August 31st, 2017 AT 2:17 PM
Tiny
MILLERJT
  • 2003 CHEVROLET SUBURBAN
  • 4WD
  • AUTOMATIC
  • 120,000 MILES

The fuel pump was replaced and they had the wrong adapter so we changed that out. Went to start it and it won't start. Checked all the fuses and none were blown, tried bleeding air from the lines under the hood no gas came through when turning the key to start several times. Went back and took the tank down rechecked the lines to make sure they were connected good no gas was in the lines when I took them apart to check. I also switched the relay from the AC to the fuel pump relay just to check that and it made no differnce. You can hear the pump run when the key is in start position. Any idea what the problem may be? Thank you!
Tina

Was this
answer
helpful?
Yes
No
Thursday, August 31st, 2017 AT 2:18 PM (Merged)
Tiny
HMAC300
  • EXPERT
  • 49,802 POSTS

Is the pump in right and not installed backwards?

Was this
answer
helpful?
Yes
No
Thursday, August 31st, 2017 AT 2:18 PM (Merged)
Tiny
HMAC300
  • EXPERT
  • 49,802 POSTS

Also maybe the sock is plugged or enough gas in tank? Should have at lest 5 gallons

Was this
answer
helpful?
Yes
No
Thursday, August 31st, 2017 AT 2:18 PM (Merged)
Tiny
MILLERJT
  • MEMBER

Yes it is installed correctly and there is more than 5gallons in the tank.

Was this
answer
helpful?
Yes
No
Thursday, August 31st, 2017 AT 2:18 PM (Merged)
Tiny
HMAC300
  • EXPERT
  • 49,802 POSTS

Without really looking at this I can't give you a definitive answer. Unless the wires broke going to the pump but you said you hear it running. Only thing it would leave is a blocked line. Can you blow air back through it? The only thing I can think of is an internal leak or the check valve isn't any good

Was this
answer
helpful?
Yes
No
Thursday, August 31st, 2017 AT 2:18 PM (Merged)
Tiny
PELONCABRON
  • 2003 CHEVROLET SUBURBAN
  • V8
  • 4WD
  • AUTOMATIC
  • 150,000 MILES

I took the instrument cluster out and fixed the speedometer put everything back together it wants to start it just is not completing the start. I'm not sure what to do I replaced the battery cause it had a bad cell but still won't run what do you think it is I also checked the fuses there are none burnt out.

Was this
answer
helpful?
Yes
No
Thursday, August 31st, 2017 AT 2:18 PM (Merged)
Tiny
HMAC300
  • EXPERT
  • 49,802 POSTS

Anytime battery is disconnected your may need to reset security system see pic.

Was this
answer
helpful?
Yes
No
Thursday, August 31st, 2017 AT 2:18 PM (Merged)
Tiny
CAMPDO49
  • 2003 CHEVROLET SUBURBAN

Electrical problem
2003 Chevy Suburban V8 Four Wheel Drive Automatic 180000 miles

3 mounts ago I parked my truck at work, after work it would not start ( I had a 1/4 tank of gas) I add 3 gal of gas to the tank and it cranked (yes the fuel gage works).

A few weeks later it did the same thing, I add a couple gal of gas to the tank and it cranked.

As long as I keep half a tank of gas I have no problem with starting.

Now I am having intermittent a loss of power and cutting off with more than a 1/2 tank of gas (sometime with a full tank of fuel).

It seems to happen more when the vehicle has set for a time idling, then again I drove 200 miles and it happened when I got off the interstate.

I have replaced the fuel filter and swapped out the f/pmp relay.

I have had the same locking fuel cap on the vehicle for 3 years.

Was this
answer
helpful?
Yes
No
Thursday, August 31st, 2017 AT 2:19 PM (Merged)
Tiny
JDL
  • EXPERT
  • 16,353 POSTS

Welcome to the forum, next time you have a problem, use a gage and check fuel pressure. I glanced through some bulletins on your vehicle, the only thing that caught my attention was improper fuel gage readings?

Was this
answer
helpful?
Yes
No
Thursday, August 31st, 2017 AT 2:19 PM (Merged)
Tiny
BRANDYN
  • 2003 CHEVROLET SUBURBAN

Transmission problem
2003 Chevy Suburban V8 Four Wheel Drive Automatic

Just had transmission rebult. So I Put it back in and car wont start. It will start if I cross starter. Is there a reset on something that I dont know about?

Was this
answer
helpful?
Yes
No
Thursday, August 31st, 2017 AT 2:19 PM (Merged)
Tiny
RASMATAZ
  • MEMBER

Did you connect the park and neutral position switch?

Was this
answer
helpful?
Yes
No
Thursday, August 31st, 2017 AT 2:19 PM (Merged)
Tiny
BRANDYN
  • MEMBER

Yes and adjusted shift cable where shift indicator lines up in every position correctly justed stopped by chevy dealer there is no restet

Was this
answer
helpful?
Yes
No
Thursday, August 31st, 2017 AT 2:19 PM (Merged)
Tiny
RASMATAZ
  • MEMBER

Do you have power to the park/neutral position switch in Park position -if not best check and test the ignition switch

Was this
answer
helpful?
Yes
No
Thursday, August 31st, 2017 AT 2:19 PM (Merged)
Tiny
MRREMOTE@WINDSTREAM.NET
  • 2003 CHEVROLET SUBURBAN

Engine Performance problem
2003 Chevy Suburban V8 Two Wheel Drive Automatic

I let my suburban set for 1 week in cold weather (20 degrees) with very litle gas. Tried to start it. Fuel pump did pressure noise no problem. Engine turns over but won't start. Added gas up to 1/4 tank but no luck. Ideas?

Thank you
BJ

Was this
answer
helpful?
Yes
No
Thursday, August 31st, 2017 AT 2:19 PM (Merged)
Tiny
JACOBANDNICKOLAS
  • EXPERT
  • 68,227 POSTS

Hi:
You need to check for two things, fuel pressure and spark to the plugs. One will most likely be missing.

Let me know what you find.

Joe

Was this
answer
helpful?
Yes
No
Thursday, August 31st, 2017 AT 2:19 PM (Merged)
Tiny
TJ2003
  • 2003 CHEVROLET SUBURBAN

Electrical problem
2003 Chevy Suburban V8 Four Wheel Drive Automatic 125000 miles

Daughter ran out of gas. I put gas in it and now it won't start. NO problems prior to this. Read manuel about fuses and found that the ignition and heated seats are on the same fuse, the heated seats do NOT work so I started looking at fuses and could not find a problem, although some of the fuses are in a clusters and could not see if there was a problem with some.

Thanks
TJ

Was this
answer
helpful?
Yes
No
Thursday, August 31st, 2017 AT 2:19 PM (Merged)
Tiny
BLACKOP555
  • EXPERT
  • 10,537 POSTS

Ahhh, running a vehicle out of fuel. Happens to all of us!

When a vehicle is ran out of fuel it usually causes the fuel pump to go out, especially if its original and has accumulated a lot of miles or is used to being ran around with just vapors in the tank. There is where im sure your problem is.

Was this
answer
helpful?
Yes
No
Thursday, August 31st, 2017 AT 2:19 PM (Merged)
Tiny
ANSWERED PRAYER STU
  • 2003 CHEVROLET SUBURBAN

Transmission problem
2003 Chevy Suburban V8 Four Wheel Drive Automatic

I JUST R & R'D MY TRANS IN OUR 2003 SUBURBAN W/ USED JASPER TRANS AND NOW IT WONT START.I SAW WHERE BRANDON HAD ASKED THE SAME? AND WAS WONDERING WHAT HIS FINAL ANSWER WAS. PLEASE LET ME KNOW ASAP AS I HAVE THIS ONE SOLD.
DID I MENTION THAT THIS IS THE 2ND TRANS FOR THIS AUTO, AND I HAVE HAD TO PUT (2 TRANSFER CASES AND (2) REAR ENDS IN MY 2002 2500 HD P/U

Was this
answer
helpful?
Yes
No
Thursday, August 31st, 2017 AT 2:19 PM (Merged)
Tiny
RASMATAZ
  • MEMBER

I JUST R & R'D MY TRANS IN OUR 2003 SUBURBAN W/ USED JASPER TRANS AND NOW IT WONT START

Is it cranking over? If not could be the park and neutral switch when you put it back together-now if its cranking over and wil no start could be fuel or spark problem

Was this
answer
helpful?
Yes
No
Thursday, August 31st, 2017 AT 2:19 PM (Merged)

Please login or register to post a reply.

Recommended Guides