It clicks but doesnt starts

Tiny
TYQUANHUNTER
  • 2000 NISSAN ALTIMA
  • 117,000 MILES

It clicks but doesnt starts. I had the spark plugs changed, also the oil and the gas pump. This started last sunday it was driving smooth like its always has since I got it for my birthday in jan. Then it was that I would accelerate and it would go real slow then finally pick up speed. Then I got home this is all I the same day I parked it woke up to go to work did not want to start! What do I dooooooo someone helppp please

Do you
have the same problem?
Yes
No
Saturday, January 26th, 2013 AT 2:57 PM

4 Replies

Tiny
HMAC300
  • EXPERT
  • 46,998 POSTS

Put a charge on battery andfirst or jump car to get started. Then have battery and charging system checked.

Please consider a donation to help us answer more questions.
Was this
answer
helpful?
Yes
No
Saturday, January 26th, 2013 AT 4:31 PM
Tiny
TYQUANHUNTER
  • MEMBER

I did and it wants to start but doesnt goes vroom vroom vroooummm the goes real low and dies

Was this
answer
helpful?
Yes
No
Saturday, January 26th, 2013 AT 5:51 PM
Tiny
TYQUANHUNTER
  • MEMBER

I want to cry I need her to start ughhhhhand you know im a blnde when it comes to cars but I want to try and fix it mysef before I bring it o the shop

Was this
answer
helpful?
Yes
No
Saturday, January 26th, 2013 AT 5:52 PM
Tiny
HMAC300
  • EXPERT
  • 46,998 POSTS

Scan for codes and check fuel pressure first if you dont do this you will never know wha tis wrong with it.

Please consider a donation to help us answer more questions.
Was this
answer
helpful?
Yes
No
Saturday, January 26th, 2013 AT 7:56 PM

Please login or register to post a reply.

Related Spark Plug Replace/Remove Questions

Help us by donating