My engine does not start I have changed the spark plugs, but still does the same thing.

Tiny
SHIRA D. CEASAR
  • MEMBER
  • 1999 NISSAN ALTIMA
  • 4 CYL
  • AUTOMATIC
  • 150,000 MILES
My son was on his way to work. It stopped on him and he had to roll to the side of the rode. I have changed the spark plugs, but still does the same thing.
Do you
have the same problem?
Yes
No
Sunday, January 8th, 2017 AT 3:16 PM

2 Replies

Tiny
JOHNNY G.JR
  • MEMBER
This sounds like the crankshaft angle sensor or the fuel pump has gone out, when you turn the key to the on position without cranking the engine over can you hear the fuel pump run in the tank for 5 seconds? These guides should help us fix it.

https://youtu.be/dCjmRL3p4Cs

and

https://www.2carpros.com/articles/car-cranks-but-wont-start

Also, lets run the codes to see what come up.

https://www.2carpros.com/articles/checking-a-service-engine-soon-or-check-engine-light-on-or-flashing

Please run down these guides and report back.
Was this
answer
helpful?
Yes
No
+1
Saturday, October 26th, 2019 AT 11:49 AM
Tiny
KEN
  • ADMIN
Hey SHIRA,

It could be any number of things, we have made a very comprehensive free guide on what to check first to get the problem fixed,

https://www.2carpros.com/articles/car-cranks-but-wont-start

Please let us know what you find so it will help others.

Best, Ken
Was this
answer
helpful?
Yes
No
Saturday, October 26th, 2019 AT 11:49 AM

Please login or register to post a reply.

Related Engine Not Running Content

Sponsored links