TURN SIGNALS DONT WORK

  • Tiny
  • 501bob
  • 2000 MITSUBISHI MONTERO
  • 120,000 MILES

2000 Mitizubishi Montero Sport. Turn signals do not work.

Do you
have the same problem?
Yes
No
Monday, June 11th, 2012 AT 7:35 PM

6 Replies

  • Tiny
  • KHLow2008
  • EXPERT
  • 41,977 POSTS

Have you checked the fuses?
Are the hazard lights working?

Was this
answer
helpful?
Yes
No
+2
Monday, June 11th, 2012 AT 7:37 PM
  • Tiny
  • 501bob
  • MEMBER

Hazards lights are working.

Was this
answer
helpful?
Yes
No
+12
Monday, June 11th, 2012 AT 7:54 PM
  • Tiny
  • KHLow2008
  • EXPERT
  • 41,977 POSTS

Fuse # 12.

Was this
answer
helpful?
Yes
No
-1
Tuesday, June 12th, 2012 AT 6:02 PM
  • Tiny
  • 501bob
  • MEMBER

Located 10 amp, fuse is okay.

Was this
answer
helpful?
Yes
No
+2
Wednesday, June 13th, 2012 AT 8:32 PM
  • Tiny
  • KHLow2008
  • EXPERT
  • 41,977 POSTS

Okay, you would need to perform some testings to determine what could be wrong. If the fuse is good and has power to it, then the problem would most likely be with the switch or the wiring connectors there.

Get a test light or DVOM and I will get some schematics for you.

Was this
answer
helpful?
Yes
No
+5
Thursday, June 14th, 2012 AT 1:57 PM
  • Tiny
  • 2CarPros Ken
  • ADMIN
  • 4,282 POSTS

Hey 501BOB,

It sounds like the turn signal switch has gone bad, here is a wiring diagram for you

Was this
answer
helpful?
Yes
No
Friday, May 6th, 2016 AT 2:40 PM

Please login or register to post a reply.

Other Turn Signal Light Not Working Questions