CLUTCH WON'T REALESE AFTER 45 MIN DRIVE/WARMUP

1997 Geo Tracker

Tiny

Triallity

June, 10, 2011 AT 6:11 AM

My problem is when after driving an hour after a cold start the clutch doesn't release. When cold the clutch releases and holds fine but once you get to operating temperature you have around 15mins before the it won't release. I just got this vehicle and found a document about 20k ago the release bearing was grinding so a shop replaced the clutch (full kit) and also found the input spline on the transmission and the pilot bearing in the flywheel damaged/worn. All of this was apparently repaired. Right now I have the clutch cable adjustment nut (its a mechanical clutch release) all the way down for maximum leverage to release the clutch. Even like this when cold the friction point is half way on the pedal travel. I'm hoping its just the cable getting expanded by the engine but my gut says theres probably more than that.

FOUND 290 RELATED QUESTIONS

3 Answers

Tiny

Docfixit

June, 10, 2011 AT 1:47 PM

Try this need free play in cable adjust free play according to diagram

Tiny

Triallity

June, 12, 2011 AT 6:09 AM

Thanks that helped, didn't see the index marks on there first time under. The shop put the arm few splines off and that decreased the leverage. Put it normally and adjusted it again and now releases fine after the warming up.

Tiny

Docfixit

June, 12, 2011 AT 7:04 PM

Good news as clutch disc wear will tighten up on this design

Please login or register to post a reply.

Clutch/Flywheel/Rear Main Seal Replacement
Pulling an Auto Trans? Easy Instructions