POWER LOCKS AND DOME LIGHT

1997 Buick Lesabre

Tiny

pcdj64

December, 15, 2011 AT 5:46 PM

Once in a while the dome light does not work either by door or dash switch, at the same time the power locks do not work, the chime for the alarm when you press lock is a lot weaker.

all fuses are good, if I try the door lock button a bunch of times the locks will start to work and the dome light will come on when you open the door, also the chime is back to it's normal sound, when I press lock, once I close the door it automatically locks them, does not automatically lock when the light and locks fail

FOUND 6122 RELATED QUESTIONS

Light Codes

41 ANSWERS

Lighting Issue

5 ANSWERS
8 IMAGES

14 Answers

Tiny

saturntech9

December, 15, 2011 AT 6:28 PM

Do you have a multimeter to do some testing?

Tiny

pcdj64

December, 15, 2011 AT 7:08 PM

I have a pretty decent multi-meter

Tiny

saturntech9

December, 15, 2011 AT 9:38 PM

Check to see if the multifunction alarm and lighting module has a loose connection somewhere at the module. That is the only place I see that those two circuits have in common. Also I posted a diagram that shows where it is. Let me know what you find.

Tiny

pcdj64

December, 15, 2011 AT 10:05 PM

The module is behind the glove box on the firewall, I pushed on the 2 connectors and they seem to be tight.
It is listed as a MALL, is that the body control module?
I knew which box it was by pressing the door lock button with a finger on the box and felt the relay click when the doors locked.
I looked up body control module and the 2 numbers they offer do not match the numbers on that box at all.
As of right now everything is working.

Tiny

saturntech9

December, 15, 2011 AT 10:33 PM

So what is the part number on it?Did you unplug the connectors and make sure there are no open terminals?

Tiny

pcdj64

December, 15, 2011 AT 11:23 PM

All of the wires in the connectors are tight, none broken
it is something like 1409230 I can't remember the exact bumber

Tiny

saturntech9

December, 15, 2011 AT 11:46 PM

If you give me the exact number I think I found one online.I was asking if you unplugged the connectors and look at the the silver terminal openings where the connectors from module go in. If those look like there open instead of closed causing a loose connection.

Tiny

pcdj64

December, 16, 2011 AT 12:04 AM

I will unplug them to check the silver part in the morning, it is 1029231 I was a little off lol. Doesn't a new one have to be programmed or am I thinking of the wrong part?

Tiny

saturntech9

December, 16, 2011 AT 3:11 AM

It doesnt say anything about reprograming it after replacing it.

Tiny

pcdj64

December, 16, 2011 AT 12:26 PM

I am checking for loose silver connectors this morning
is that part available online? I couldn't find one
i will let you know what I find

thank you for all of your help

Please login or register to post a reply.

Cabin Air Filter Replacement
Seat Switch Replacement GMC Yukon
Door Panel Removal & Speaker Replacement