NEED HELP DIAGNOSING TRANSMISSION?

1994 Saturn SW2

Tiny

brentkay73

January, 8, 2012 AT 10:07 PM

My son just bought a 94 sw2, Automatic tranny. When driving and you slow down, the check engine light comes on and it does not shift into third.(Kinda like limp mode) If you pull over and shut the car off then restart it. Its fine for a few. It does only happen after the car warms up. Also when you put it into reverse you have to step on the gas in order for it to engage in to it. Checked the codes when light was on and had code 23 (no 3rd gear I believe). Any idea would be a great help' Thanks.
Brent

FOUND 13674 RELATED QUESTIONS

Transmission Flare

92 ANSWERS
4 IMAGES

Transmission Problem

19 ANSWERS
21 IMAGES

3 Answers

Tiny

saturntech9

January, 8, 2012 AT 10:49 PM

Sounds like you have a issue with the pressure regulator valve in the transmission. Thats very common on those when the pressure becomes too low you will get a delay or no reverse till you give the engine gas. It will also cause the transmission to slip and set incorrect gear ratio codes indicating a slipping clutch pack. The first thing you need to do is buy a transmission pressure gauge test kit if your going to fix this yourself. You will also need a air compressor to air check each gears clutch piston and the reverse servo piston. Otherwise you will have to take it to a transmission shop and usually theywant to take it apart and rebuild the transmission before testing anything.

Tiny

brentkay73

January, 9, 2012 AT 4:18 PM

Thanks for the response. I'm currently in college for Automotive but dont have much experience with diagnosing transmissions. I have access to a transmission pressure test kit and know how to use it. What should it read and is there a step by step site I can go to on how to test the gear clutch pistons? Thank you so much!

Tiny

saturntech9

January, 9, 2012 AT 5:27 PM

I can help you thru all the steps lets start by checking the pressure. First remove the air box in front battery bellow that you will see the transmission filter. Right next to the filter is the transmission temp sensor its little. Unscrew the temp sensor and remove it then screw in the transmission pressure gauge tester adapter. Then start the engine and make sure there are no leaks. It should read about 60psi. Then pull the line pressure actuator fuse it should read a min of 175psi but most of the time will read well over 200psi. If it reads bellow 175psi give it a little throttle see if the pressure raises over 200psi. Let me know what you find.

Please login or register to post a reply.

Code Read Retrieval/Clear Honda Civic
Code Read Retrieval/Clear Scion XD
Code Read Retrieval/Clear Chevrolet Camaro
How to gather codes Ford Explorer