Speedometer stopped working

Tiny
GERALD6364
  • MEMBER
  • 2000 MERCURY MOUNTAINEER
  • 4 CYL
  • 4WD
  • AUTOMATIC
  • 183,946 MILES
My wife and I were going to the store and gray smoke come from the instrument cluster and the speedometer quit working along with the wind shield wipers, the dome lights and the power windows. I changed the gem module and fuses and relays. What can it be?
Do you
have the same problem?
Yes
No
Tuesday, November 13th, 2018 AT 3:10 PM

37 Replies

Tiny
KEN
  • ADMIN
It sounds like the cluster has burned out. Here is a video of the rebuild unit being installed into a similar car. Where there burned fuses?

https://youtu.be/_HEC44xENxw

Check out the diagrams (below). Please let us know what happens.

Cheers, Ken
Was this
answer
helpful?
Yes
No
Thursday, November 15th, 2018 AT 4:50 PM
Tiny
GERALD6364
  • MEMBER
I replaced it with a new cluster and it is still doing the same thing.
Was this
answer
helpful?
Yes
No
Thursday, November 15th, 2018 AT 6:54 PM
Tiny
KEN
  • ADMIN
Sorry about that, can you check to see if you are getting power out of the ignition switch with the switch on check the black/light green and light green and purple. Here is a guide to help:

https://www.2carpros.com/articles/how-to-use-a-test-light-circuit-tester

Here is a wiring diagram so you can see how it works.
Was this
answer
helpful?
Yes
No
Friday, November 16th, 2018 AT 12:51 PM
Tiny
GERALD6364
  • MEMBER
It does not have power going to it. Now what?
Was this
answer
helpful?
Yes
No
Sunday, November 18th, 2018 AT 6:50 PM
Tiny
KEN
  • ADMIN
Does the car run? Do you have power at the yellow wires going into the ignition switch?
Was this
answer
helpful?
Yes
No
Monday, November 19th, 2018 AT 11:49 AM
Tiny
GERALD6364
  • MEMBER
Yes, we have been driving it to the grocery store, but the speedometer power windows and dome lights not working.
Was this
answer
helpful?
Yes
No
Monday, November 19th, 2018 AT 1:12 PM
Tiny
KEN
  • ADMIN
If you do not have power at the black/light green and light green and purple with the switch in the on position the ignition switch is bad and needs to be replaced. Here are diagrams to show you how. Check out the diagrams (below). Please let us know what happens.
Was this
answer
helpful?
Yes
No
Tuesday, November 20th, 2018 AT 9:33 AM
Tiny
GERALD6364
  • MEMBER
I was wondering and I should have told you earlier my roof is leaking. Could it have shorted something out?
Was this
answer
helpful?
Yes
No
Tuesday, November 20th, 2018 AT 4:19 PM
Tiny
GERALD6364
  • MEMBER
Can you tell me where the battery saver relay is located?
Was this
answer
helpful?
Yes
No
Thursday, November 22nd, 2018 AT 11:19 AM
Tiny
KEN
  • ADMIN
Yes, water can cause all kinds of issues. Battery Saver Relay - In relay module. Here is a guide to help you test it:

https://www.2carpros.com/articles/how-to-check-an-electrical-relay-and-wiring-control-circuit

Check out the diagrams (below). Please let us know what you find.

Was this
answer
helpful?
Yes
No
Friday, November 23rd, 2018 AT 11:05 AM
Tiny
GERALD6364
  • MEMBER
Okay, I will.
Was this
answer
helpful?
Yes
No
Sunday, November 25th, 2018 AT 9:13 AM
Tiny
GERALD6364
  • MEMBER
I changed the ignition switch. Gem module. All the fuses and relays and it is still doing the same thing. I checked the wire's again and now I am getting power to the light green and purple but no power to the black and light green wire. Now what do I do?
Was this
answer
helpful?
Yes
No
Sunday, December 2nd, 2018 AT 7:21 AM
Tiny
KEN
  • ADMIN
It sounds like when the cluster blew it took out the VSS. Here is its location. (Output speed sensor)
Was this
answer
helpful?
Yes
No
Monday, December 3rd, 2018 AT 9:18 AM
Tiny
GERALD6364
  • MEMBER
Does it have anything to do with the power windows windshield wipers and the dome light not working?
Was this
answer
helpful?
Yes
No
Monday, December 10th, 2018 AT 10:29 PM
Tiny
KEN
  • ADMIN
No. Can you use a test light to check for power at fuse # 18 and #26 and maxi fuse #4?

https://www.2carpros.com/articles/how-to-use-a-test-light-circuit-tester

Check out the diagrams (below). Please let us know what you find.

Cheers, Ken
Was this
answer
helpful?
Yes
No
Tuesday, December 11th, 2018 AT 11:49 AM
Tiny
GERALD6364
  • MEMBER
The ones on the inside or outside?
Was this
answer
helpful?
Yes
No
Wednesday, December 12th, 2018 AT 3:09 AM
Tiny
KEN
  • ADMIN
They are both the maxi fuse is for sure under the hood.
Was this
answer
helpful?
Yes
No
Wednesday, December 12th, 2018 AT 10:24 AM
Tiny
GERALD6364
  • MEMBER
Okay, I will check them tomorrow.
Was this
answer
helpful?
Yes
No
Wednesday, December 12th, 2018 AT 2:59 PM
Tiny
GERALD6364
  • MEMBER
I checked all of the fuses and they are showing 12 volts.
Was this
answer
helpful?
Yes
No
Thursday, December 13th, 2018 AT 1:55 PM
Tiny
KEN
  • ADMIN
Then the only thing that ties these together is the GEM but you said you replaced that right? Let's check the wiring to the GEM. Here is a guide and wiring diagrams below:

https://www.2carpros.com/articles/how-to-check-wiring

Check fuses 25, 10, 28, 20, check for power and ground at the module.
Was this
answer
helpful?
Yes
No
Friday, December 14th, 2018 AT 10:36 AM

Please login or register to post a reply.

Recommended Guides