Turn signals not working properly

Tiny
DARCYDOODLE
  • MEMBER
  • 2004 PONTIAC GRAND PRIX
  • 2WD
  • AUTOMATIC
  • 126,000 MILES
My front turn signals weren't working. The turn signal lights on the dashboard would both blink rapidly. The back turn signals work fine. I replaced the front driver side turn signal bulb and now it flashes at regular speed, and the passenger side flashes now as well. Now my problem is that your front turn signals both flash when I signal a left or a right turn. The back signals still only flash the correct direction that I'm trying to signal. Sorry I hope this makes sense.
Do you
have the same problem?
Yes
No
Thursday, January 13th, 2022 AT 7:05 AM

1 Reply

Tiny
JOE F
  • EXPERT
Hi,

Somehow, we have a short to power at the front two only. Did both front stop at the same time?

I attached a wiring schematic below. The one thing that is standing out to me is the right front signal light connector. If those two pins in the connector cross, it could allow this to happen.

One wire is brown and the other should be light blue at the connector. Inspect that first. Make sure the light socket internal pins are not damaged or touching as well as the wiring to it.

Next, if that checks good, we may have a problem with the multi-function switch. However, at this point, which is unlikely.

Inspect wiring, connectors, and sockets for damage or anything that can cause them to short.

Let me know what you find.

Joe

See pic below. Note: I highlighted all wires related to the front signal lights.
Was this
answer
helpful?
Yes
No
Thursday, January 13th, 2022 AT 8:10 PM

Please login or register to post a reply.

Sponsored links