Truck will only blow air out of vents.

Tiny
LIVANGRIC
  • MEMBER
  • 1993 GMC SIERRA
  • 115,000 MILES
If I swap to defrost it still s blows out of the vents and the same if I switch it to floor. I have looked at the door linkage and I think some pieces are missing. I can move the doors manually by hand and they move freely and work properly. I tested the motor that hooks up on the side and it works fine as well. I think pieces are missing. Did not know what these pieces were called and have not been able to find them anywhere. Was wondering if anyone knew where to get these and maybe where I could see a picture on how they all go back together?

Thanks
Do you
have the same problem?
Yes
No
Friday, October 18th, 2013 AT 11:47 AM

7 Replies

Tiny
HMAC300
  • EXPERT
Check for a vacuum leak first it may be leaking vacuum and not working the motors start at engine then go to hvac unit
Was this
answer
helpful?
Yes
No
Friday, October 18th, 2013 AT 11:58 AM
Tiny
LIVANGRIC
  • MEMBER
The motor that moves these levers is strictly electrical. There are no vacuum lines on this at all or that I have seen. The motor wants to do the correct thing as it moves as it should, but there are pieces missing in the linkage on the outside of the airbox and they are not all connected together properly. I am really needing to find those linkage pieces and a diagram on how it goes back together. Thanks for your response.
Was this
answer
helpful?
Yes
No
Friday, October 18th, 2013 AT 12:59 PM
Tiny
HMAC300
  • EXPERT
Ok here is a diagram it is cable controlled so if there is anything gone it's the cables. See pic
Was this
answer
helpful?
Yes
No
-1
Friday, October 18th, 2013 AT 1:04 PM
Tiny
HMAC300
  • EXPERT
If you don't have the cables her eis another view with actuators there is some linkage but it doesnt' operate doors. The actuators do. Try pulling your hvac fuse as the actuators sometimes reset. You need to leave fuse out for 60 seconds with key on then reinstall.
Was this
answer
helpful?
Yes
No
Friday, October 18th, 2013 AT 1:08 PM
Tiny
LIVANGRIC
  • MEMBER
Thanks for that that is really helpful. The linkage moves with the actualtor when turned on so I thought the linkage must be what moves the doors. If it is not needed why would it even be there? Weird. Anyway I will look into this today when I get home and report back.

Thanks
Was this
answer
helpful?
Yes
No
Friday, October 18th, 2013 AT 2:18 PM
Tiny
LIVANGRIC
  • MEMBER
OK, I tore everything apart last night and looked at this. This system is completely electric. It has no cables or Vacuum whatsoever. I took the Mode Actuator off and found gears broken inside. I put a new one on and now the vent and floor work perfectly, but I still have no defrost and the mode selector on HVAC Control is blinking like it is not working properly. There has to be something else, and I am confident once the issue is resolved that the HVAC Control will stop blinking.
Was this
answer
helpful?
Yes
No
Saturday, October 19th, 2013 AT 6:29 AM
Tiny
HMAC300
  • EXPERT
The light flashes because there is a mode door fault it will do that for 2 minutes so see if the linkage Is jammed or misaligned or on wrong. That is why the actuator gears broke probably it may be together wrong. We only have what we sent you in the pic to align it.
Was this
answer
helpful?
Yes
No
Saturday, October 19th, 2013 AT 8:22 AM

Please login or register to post a reply.

Recommended Guides