Transmission whine

Tiny
BURNIN1961
  • MEMBER
  • 2008 CHEVROLET COBALT
  • 2.0L
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 140,000 MILES
The transmission does not seem to want to shift into high gear, I feel the first to second and the second to third shift, but nothing after that. The rpm's are at 2,000 at 70 mph. I had the codes read it was P061. Camshaft/crankshaft sensor is bad. Is this possible?
Do you
have the same problem?
Yes
No
Monday, May 23rd, 2016 AT 7:58 PM

5 Replies

Tiny
HMAC300
  • EXPERT
There is no code p061 go to auto parts have them scan it and then get back us. If it is a P016 then crank/cam sensor is out of correlation and a local professional will have to set it with the scanner. Have it re scanned. It may be your torque converter clutch is not applying for whatever reason.
Was this
answer
helpful?
Yes
No
+1
Tuesday, May 24th, 2016 AT 6:27 AM
Tiny
BURNIN1961
  • MEMBER
Hello HMAC300. You are right my dyslexia kicked in it was a P016 code. Would replacing the Cam sensor cause the vehicle to shift better or at least make it to high gear so it did not scream so loud?
Was this
answer
helpful?
Yes
No
Tuesday, May 24th, 2016 AT 9:53 PM
Tiny
HMAC300
  • EXPERT
You can't replace the cam sensor to fix the 016 code it's like the engine is out of time and needs to be retimed. You can't do it because it takes a pro scanner to do it it is done with the machine. I doubt it will have anything to do with your whine. You may have a reaction carrier(planetary gear set) going bad
Was this
answer
helpful?
Yes
No
Wednesday, May 25th, 2016 AT 6:13 AM
Tiny
BURNIN1961
  • MEMBER
Should the 3-4 shift be as detectable as the others, I can feel and hear the 1-2 and 2-3 shifts but after that it just sounds like it's running high but the RPM meter shows 2500 at 70mph. I heard about a TCM grounding issue could this be an issue for me, if you have any details on that can you post something a diagram or something. Thank you.
Was this
answer
helpful?
Yes
No
Wednesday, May 25th, 2016 AT 1:24 PM
Tiny
HMAC300
  • EXPERT
If you are running 2500 at 70 then your converter clutch may not be applying have a trans guy check this out.
Was this
answer
helpful?
Yes
No
Wednesday, May 25th, 2016 AT 4:03 PM

Please login or register to post a reply.

Recommended Guides