1989 TERCEL ELECTRICAL PROBLEM

  • Tiny
  • Sponjahgirl
  • 1989 TOYOTA TERCEL

Help! I don't know what to do about my 1989 Toyota Tercel. The engine is a 1.5L SOHC 4-cylinder with 112,694 miles. Recently, the tail lights, instrument panel, blinkers, window wipers, and radio would stop working while I was driving and then come back on after a little bit. Then my car wouldn't start sometimes. I fixed that problem with a little button, and everything seemed to fine, but the other issues came back and are actually much worse. Now nothing comes on at all, total bummer. I thought it might be the alternator since the charge battery light kept flickering on, but after testing with a DMM, and the fact that my headlights are still going strong, I ruled that out. I've also noticed that the fuse box on the driver side holds everything that happens to be malfunctioning. The fuses seem fine and I even tried pulling them all out to test if one might be faulty. Could I be wrong and it is the alternator? Or is there a bad wire or connection? If so, where I should I look to fix it and how? On a side note, there's a couple of curious things. The radio will come on when I turn the key, but as soon as I push the button to start my car it doesn't work anymore. Also, if I go really fast on the freeway, sometimes the gas gauge will work, as well as a few other things. For a moment at least. :Cry:

Do you
have the same problem?
Yes
No
Wednesday, July 11th, 2007 AT 6:01 AM

1 Reply

  • Tiny
  • Rasmataz
  • MEMBER

This button I assumed is for the starting circuit. I will test the ignition switch it sounds like its going whacko!

Was this
answer
helpful?
Yes
No
Sunday, July 29th, 2007 AT 5:26 AM

Please login or register to post a reply.

Other Instrument Cluster Gauge Fuel Level Questions