1999 Toyota 4Runner 99 4Runner wont start!

Tiny
LIZZ
  • MEMBER
  • 1999 TOYOTA 4RUNNER
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 120,000 MILES
My 99 4runner will start the first time I try to start it. But after I drive it and turn it off it wont start for a while. At least a couple of hours. It's not running hot, and the engine purrs like a kitten when it does start. Timing belt has been changed, along with o-rings for the injectors, and tps. I have fuel pressure from what we can tell. It turns over but it doesnt seem to be getting gas. I have had it at 3 different shops and no one can figure it out. Help! Crank sensor? Fuel pump? I just dont know. My dads tacoma does the exact same thing. They told him it was the throttle body, it was cleaned and no go. We did the same to mine.
Do you
have the same problem?
Yes
No
Wednesday, June 16th, 2010 AT 11:46 AM

1 Reply

Tiny
RASMATAZ
  • EXPERT
Lets do below for a start to determine if its fuel or spark related issue and get back with some results

Get a helper disconnect a sparkplug wire or 2 and ground it to the engine atleast 3/16 away from ground-have helper crank engine over-do you have a snapping blue spark? If so-you have a fuel related problem, check the fuel pressure to rule out the fuel filter/fuel pump/pressure regulator and listen to the injector/s are they pulsing or hook up a noid light. No snapping blue spark continue to troubleshoot the ignition system-power input to the coil/coil packs, coil's resistances, distributor pick-up coil, ignition control module, cam and crank sensors and computer Note: If it doesn't apply disregard it
Was this
answer
helpful?
Yes
No
Wednesday, June 16th, 2010 AT 5:03 PM

Please login or register to post a reply.

Sponsored links