1996 Subaru Legacy mass air flow sensor


1996 Subaru Legacy 4 cyl Automatic

this car is driving me nuts. Replaced MAF 3 times, ran o.K. For 2 days now acting up again. MAF code still coming up. What could possibly be wrong? Its only got the 1 hose on it, and it seems fine. HELP!

Do you
have the same problem?
Tuesday, October 26th, 2010 AT 3:58 PM

1 Reply


Inspect for the following conditions:

An incorrectly routed harness--Inspect the harness of the MAF sensor in order to verify that it is not routed too close to the following components:
- The secondary ignition wires or coils
- Any solenoids
- Any relays
- Any motors
A low minimum air rate through the sensor bore may cause this DTC to set at idle or during deceleration. Inspect for any vacuum leaks downstream of the MAF sensor.
A wide open throttle (WOT) acceleration from a stop should cause the MAF sensor g/s display on the scan tool to increase rapidly. This increase should be from 6-12 g/s at idle to 230 g/s or more at the time of the 1-2 shift. If the increase is not observed, inspect for a restriction in the induction system or the exhaust system.
The barometric pressure (BARO) that is used in order to calculate the predicted MAF value is initially based on the MAP sensor at key ON.
When the engine is running the MAP sensor value is continually updated near WOT. A skewed MAP sensor will cause the calculated MAF value to be inaccurate. The value shown for the MAP sensor display varies with the altitude. With the ignition ON and the engine OFF, 103 kPa is the approximate value near sea level. This value will decrease by approximately 3 kPa for every 305 meters (1,000 feet) of altitude.
A high resistance on the ground circuit of the MAP sensor can cause this DTC to set.
Any loss of vacuum to the MAP sensor can cause this DTC to set.

Was this
Tuesday, October 26th, 2010 AT 9:12 PM

Please login or register to post a reply.

Recommended Guides