Rough idle, using more gas, poor acceleration?

Tiny
FANATICALMESS
  • MEMBER
  • 2009 TOYOTA COROLLA
  • 1.8L
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 198,000 MILES
I noticed my engine was a little louder and shaking a bit more than usual, using a little more gas, and the acceleration became worse. I didn’t get a check engine light for about 3 days after noticing these issues. But I did some extensive research online and decided to replace all of my spark plugs. That didn’t fix the issue, so I went to AutoZone to get a code reading to find out what exactly was wrong with my car. The reading specified that I was getting a misfire in cylinder 2 and 3. So I switched the ignition coils around and waited for my check engine light to come back on and got another reading. If it were the ignition coils, the reading should’ve said that the misfires were in cylinder 1 and 4, but it still specified that the 2nd and 3rd cylinders were misfiring. At this point I don’t know what else could be wrong besides the wires on the ignition coils.
Do you
have the same problem?
Yes
No
Tuesday, November 22nd, 2022 AT 12:50 PM

1 Reply

Tiny
KEN L
  • ADMIN
This could be a vacuum leak or the MAF sensor needs to be replaced. Please use this guide when the engine is cold only and if no leaks are found let's replace the MAF sensor. here is the location in the images below.

https://www.2carpros.com/articles/how-to-use-an-engine-vacuum-gauge

Check out the images (below). Let us know what happens and please upload pictures or videos of the problem.
Was this
answer
helpful?
Yes
No
Wednesday, November 23rd, 2022 AT 12:19 PM

Please login or register to post a reply.

Sponsored links