2003 Renault Megane

Tiny
WEBSTER68
  • MEMBER
  • 2003 RENAULT MEGANE
Engine Mechanical problem
2003 Renault Megane Manual 68000 miles

when I drive check emmisions comes up on the dash it pulls back and wont let it drive properly then it will have a surge of power then pull back again we have tryed to get a diagnostic done to find the fault but it wont link with the code reader do you have any ideas what the problem could be
Do you
have the same problem?
Yes
No
Saturday, February 14th, 2009 AT 8:07 AM

17 Replies

Tiny
DAVE H
  • EXPERT
Could be a faulty TPS (throttle position sensor) but could also be other fault. Really needs a diagnostic run to locate the exact fault. It could be the code scanner you are using is the fault. Try another dignostic scanner or garage !
Was this
answer
helpful?
Yes
No
Monday, February 16th, 2009 AT 6:55 AM
Tiny
WEBSTER68
  • MEMBER
Thank you for your reply we have had the car on a diagnostic in the garage and it still wont link up could you tell me where I can locate the throttle position sensor
Was this
answer
helpful?
Yes
No
Monday, February 16th, 2009 AT 7:52 AM
Tiny
DAVE H
  • EXPERT
TPS is located on the throttle body. Have you tried renault diagnostic software. Is this a diesel?.
Was this
answer
helpful?
Yes
No
Monday, February 16th, 2009 AT 8:02 AM
Tiny
WEBSTER68
  • MEMBER
I have not tried a renault diagnostic software my car is a 1.4 petrol
Was this
answer
helpful?
Yes
No
Tuesday, February 17th, 2009 AT 3:48 AM
Tiny
DAVE H
  • EXPERT
This could actually be a bad PCM/ECU sending wrong signals. To the TPS or other sensor. Untill it actually links we will never really know?. My next course of action would be trying renault diagnostic's to see if it will link. I could be telling you to change parts untill we locate the problem ! Which would end more expensive than a diagnostic ! In the meantime try removing and cleaning the MAF sensor on the air cleaner housing !
Was this
answer
helpful?
Yes
No
Tuesday, February 17th, 2009 AT 4:55 AM
Tiny
WEBSTER68
  • MEMBER
Thank you I will give that a go and let you know the outcome
Was this
answer
helpful?
Yes
No
Tuesday, February 17th, 2009 AT 5:27 AM
Tiny
DAVE H
  • EXPERT
You could also try a good fuel cleaner to clean the lines and fuel injectors ! Let me know how it goes
Was this
answer
helpful?
Yes
No
Tuesday, February 17th, 2009 AT 6:04 AM
Tiny
WEBSTER68
  • MEMBER
Put my car in for a diagnostic useing renault software the only thing it has picked up on is faulty oxygen sensors would this cause the problems also cant afford the garages prices to fix it do u have any ideas
Was this
answer
helpful?
Yes
No
Friday, February 20th, 2009 AT 1:57 AM
Tiny
WEBSTER68
  • MEMBER
Can anyone tell me what a transian fault is this is showing on all 4 coils
Was this
answer
helpful?
Yes
No
Friday, February 20th, 2009 AT 5:44 AM
Tiny
DAVE H
  • EXPERT
Webster68 you will need to supply me with the fault codes?
Was this
answer
helpful?
Yes
No
Friday, February 20th, 2009 AT 5:53 AM
Tiny
WEBSTER68
  • MEMBER
Dont know what the fault codes are yet I pick the car up later today and will get the codes then
Was this
answer
helpful?
Yes
No
Friday, February 20th, 2009 AT 6:21 AM
Tiny
DAVE H
  • EXPERT
When you pick up the vehicle get a print out of the codes and repost with the codes. The megane has 2 different systems of coils fitted. One full coil pack and also a coil on each plug. I really need to know the fault codes before I can offer an opinion. The oxygen sensor replacement is a real easy repair !
Was this
answer
helpful?
Yes
No
Friday, February 20th, 2009 AT 6:57 AM
Tiny
WEBSTER68
  • MEMBER
Picked the car up the codes on the coils are df072 df073 df074 df075 does that help
Was this
answer
helpful?
Yes
No
Saturday, February 21st, 2009 AT 1:27 AM
Tiny
DAVE H
  • EXPERT
How is the car running now? Our first fault was a "surge" of power now and then. Now you have bad coils or coil pack (which system is fitted?) Is it misfiring? Is it misfiring when hot? The coils going bad would not really give a "surgeing" in acceleration. You would get misfiring and the engine jerking. Kangarooing?
Was this
answer
helpful?
Yes
No
Saturday, February 21st, 2009 AT 7:38 PM
Tiny
WEBSTER68
  • MEMBER
The car is still running poor and having power surges its not misfireing we have coils in our car not coil packs
Was this
answer
helpful?
Yes
No
Sunday, February 22nd, 2009 AT 2:39 AM
Tiny
DAVE H
  • EXPERT
Do you have single COP (coil on plug) ? if so you need to replace each one .. or check the wiring going to these ? you could also check/clean or replace the CKP (crankshaft position sensor)


http://www.2carpros.com/forum/automotive_pictures/266999_cop_3.jpg

Was this
answer
helpful?
Yes
No
Monday, February 23rd, 2009 AT 9:15 AM
Tiny
WEBSTER68
  • MEMBER
Thankyou for the advice they are single coils on plug and I will try everything you have suggested again thankyou
Was this
answer
helpful?
Yes
No
Monday, February 23rd, 2009 AT 2:14 PM

Please login or register to post a reply.

Recommended Guides